x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why am I getting green artifacting when importing into the editor?

Problem: Grey textures develop strange green artifacts when imported into the engine.

To replicate: Make a simple texture, with a dark/black background, and grey details. Import to UE4 (I'm importing a 16-bit PSD straight into Unreal). Create new material, and apply new texture as base colour.

It looks like it could be compression related, but playing around with the compression settings in UE4 seem to make no difference to the outcome.

alt text

Product Version: Not Selected
Tags:
more ▼

asked Apr 30 '14 at 04:43 PM in Bug Reports

avatar image

scrcr0
288 15 18 31

avatar image [Epic] Gribbs ♦♦ STAFF Apr 30 '14 at 08:06 PM

Hello Crow87,

Thank you for the report. We would like to investigate this issue further but I have a couple of quick questions. Could you please provide the PSD in question? If not, could you please tell us more about the settings you used to save with?

Any additional information you would provide be great.

Thanks! -Sean

avatar image scrcr0 May 01 '14 at 08:34 AM

Hi Sean,

I think the PSD is a bit of a red herring. The texture you see above was quickly made as a sanity check to make sure it wasn't our original texture (link below) that was corrupted in some way.

I've tried JPEGs, TGAs, and PNGs as well as the PSD, all in various bit-depths, and still had the same result each time. The odd thing is, there are other textures we have in the project with similar low-grey/black variations, and they all imported fine with no artifacts. Not sure whether its related or not, but the textures that worked were all non-power-of-two resolutions - mipmap problem?

Here's the link to the original texture in PNG format: http://puu.sh/8uxIG.png

avatar image [Epic] Gribbs ♦♦ STAFF May 01 '14 at 07:49 PM

Hey Crow,

By adding the texture you have provided in the link, I am unable to see the green outline that you have been seeing. Is it possible to send the .uasset of the texture that has been experiencing the problem for me to test? Also, could you please provide your systems dxdiag?

Thanks for your patience, -Sean

avatar image scrcr0 May 01 '14 at 08:24 PM

Sean,

Here's a link to a few .uassets which are all attempts to import various formats of that tyre texture: https://www.wetransfer.com/downloads/16b1d7f2751d9df6c02adb710e175ede20140501202304/be5de4fa3f9e44132be58829c735bf5820140501202304/d481ca

This is one of the machines we've tested it on: http://pastebin.com/CTKbU8Wa

And another: http://pastebin.com/pAz0vt3H

avatar image [Epic] Gribbs ♦♦ STAFF May 23 '14 at 06:24 PM

Hi Crow87,

Sorry to reply to you so late. I just wanted to check in with you and see if the green outline is still occurring when you attempting to create a new material. I have been unable to reproduce it when I have tried. If not, I will close this issue out.

Thanks!

avatar image scrcr0 May 23 '14 at 10:49 PM

No problem.

Truth is, I haven't had a chance to try this again recently (other projects taking precedence). I'll make a note to give it a go when I get back into the studio on Monday.

Cheers

avatar image [Epic] Gribbs ♦♦ STAFF Jun 04 '14 at 05:41 PM

Howdy Crow87,

Any word yet on the green outline?

Thanks for your patience!

avatar image scrcr0 Jun 04 '14 at 06:16 PM

Oops, thought I'd replied to this - must've dreamt it.

Still getting the green artefacting. Have tried a bunch of different textures with various grey shades - all the same unfortunately.

avatar image [Epic] Gribbs ♦♦ STAFF Jun 04 '14 at 07:18 PM

no worries. I will keep this open and work on it.

avatar image [Epic] Gribbs ♦♦ STAFF Jun 11 '14 at 05:47 PM

Hey Crow87,

Do u mind sending the material you have shown in the picture again? I seem to have misplaced them while trying to work on your issue.

Thanks!

avatar image [Epic] Gribbs ♦♦ STAFF Jul 04 '14 at 02:58 PM

Hey crow87,

Just wanted to check in with you and see if you have fixed the issue. I am still unable to find the assets that you have sent over, so if possible, could you resend the material asset so I can reopen the issue, if the issue is still occurring.

Thanks and have a great day!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Crow87,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please feel free to open this issue again. Could you also your material and provide a screens hot of the materials details panel so I can be sure of the setup that you are using, if reopening?

Thank you.

more ▼

answered Jul 09 '14 at 03:10 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question