x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

On Mac mouse feels weird until screen is clicked

This only happens on UE running on Mac. On Windows and Linux it runs fine.

Every time I show the mouse cursor during gameplay, for example setting "Input mode to UI Only", it really feels weird when you move it around the screen, as if it had a very exaggerated acceleration and it wasn't mapped 1:1 to my movements. The moment I click on the screen, the problem goes away. I don't always have a mac available so it's hard for me to look into it and get a better report.

Anyone ever seen this behavior? Any ideas how to solve/troubleshoot it?

Product Version: UE 4.10
Tags:
more ▼

asked Feb 11 '16 at 03:17 PM in Bug Reports

avatar image

Gatherer
71 6 8 17

avatar image AndrewHurley Feb 12 '16 at 04:46 PM

Hey Gatherer,

Could you provide me with some steps so I can reproduce this in a blank project and get the issue to appear on my end?

This issue does sound interesting, but it all depends on how you are calling the mouse to the screen, and if you have changed the aspect ratio or called it to remain in a specific space like a UMG Widget.

Let me know if you have further questions.

Thanks,

Andrew Hurley

avatar image Gatherer Feb 15 '16 at 12:03 PM

For instance, it seems to happen everytime I call the "Set Input Mode Game and UI" node with the lock to viewport option checked. When I unckeck it it stops. There are UMG widgets on screen and AFAIK haven't changed the aspect ratio.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

As mentioned earlier, I need some steps to follow in order to get to the working point where you come across this issue. A good way would be to provide me with some screenshots of how and where you are calling the 'Set Input Mode Game and UI' node. You mentioned also, this issue does not occur when you uncheck, 'Lock to Viewport'? Is there a reason you need it locked to the viewport?

I am trying to gather context and more information so I can successfully reproduce this on my end.

Thank you,

Andrew Hurley

more ▼

answered Feb 16 '16 at 06:10 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question