x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Landscape - foliage/sculpting problem

hi! I got annoying landscape bug or i'm missing something important in my workflow. https://youtu.be/kVu35-26Vqk

In first few clips on video im sculpting pre-made landscape and you can see all painted foliage reacts to new shapes of landscape. I can also paint new foliage correctly.

When im starting level from scratch and sculpt landscape or paint foliage it starts to "bug" wierldy. I had this problem with other projects, ue versions and landscapes too. Is there some setting i'm missing or is this bug?

I also have another problem with some landscapes that i have created and sculpted. at some random point sculpting tools stop working and i can sculpt no more. I have tried to migrate levels to another level but still cant get tools work properly.

Product Version: UE 4.10
Tags:
more ▼

asked Feb 12 '16 at 12:28 AM in Bug Reports

avatar image

Player
0 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Player,

So when painting your foliage meshes, be sure to have the 'Collision with World' enabled which will check to make sure it is colliding with the surface it is being applied.

Collision with World

alt text

Be sure to rebuild your geometry after having checked this option on pre-painted foliage. If that is still not working, you can select the re-apply tool, scroll down to the 'Collision with World' option, select the correct foliage type, and then repaint the foliage. It will then re-locate your meshes to the geometry's surface of your landscape.

In regards to the scuplting tool not functioning after a certain time, are you able to reproduce this in a blank project, or have steps to get to this point?

Let me know if you have further questions or need additional assistance.

Thanks,

Andrew Hurley

more ▼

answered Feb 12 '16 at 04:25 PM

avatar image Keanetic Oct 24 '16 at 03:22 PM

Hello Andrew, I've encountered the same problem where the foliage did not get adjusted to surface of the landscape after the landscape have been deformed. Rebuilding geometry did not work.

I try to use the Reapply tool with "Collision with World" checked. However, instead of re-locating the meshes to the geometry's surface of landscape, it removes them. I think the engine evolved since then, see the attached picture.

alt text

Do you have another suggestion how to correct this? :)

capture.jpg (23.2 kB)
avatar image AndrewHurley Oct 24 '16 at 06:32 PM

Hey Keanetic,

So I ran some tests and did not get the same results. Can you provide me with some steps so I can reproduce the issue on my end?

Are you making sure to repaint over the selected instances when using the re-apply tool?

If your foliage has the 'Align to Normal' unchecked, some of your foliage instances might appear to be hovering since they are not checking and aligning to the direction of that particular landscape normal location.

Let me know if you have further questions.

Cheers,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Try selecting corrupted foliages with lasso tool (select the foliages before you want fix) and press End key. At least it worked for me (4.22).

more ▼

answered May 07 '19 at 03:59 PM

avatar image

BigaCubensis
115 6 78 22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question