x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Actor scale not replicating

I am seeing an issues where i have a projectile spawned on the server, and it is replicating to the clients fine. However, the server (oddly enough) is no respecting the scale of a mesh for my bullet. I have the scale set to 0.3, and the clients it looks great, however the server's versions of the bullets are at 1.0. I have seen on here that there have been some scaling replication issues. Is anyone else seeing this?

Product Version: UE 4.10
Tags:
more ▼

asked Feb 12 '16 at 04:19 AM in Blueprint Scripting

avatar image

iCode
6 1 2 4

avatar image Sean L ♦♦ STAFF Feb 12 '16 at 05:21 PM

Hello,

There was a known issue in our system, UE-14509, but it was reported as fixed in 4.9. I have just performed a test, and was able to have the scale replicate properly.

Could you please provide the information from the Class Defaults panel of the blueprint that you are not seeing replicate scale properly? Specifically, ensure that you have Replicates and Replicate Movement set to True.

avatar image iCode Feb 13 '16 at 05:08 AM

EDIT: re-uploaded pictures, didn't seem to work..

Sure thing. i think i got everything you asked for.

This shows the my projectile with the replication settings: alt text

My base projectile has a lovely pink mesh that has the scale set on it: alt text

this is the end result after i hit the fire button. Note, i set my projectile movement to zero so the bullet would just float so you could see what i see. alt text

avatar image iCode Feb 16 '16 at 02:19 AM

If there is anything else i can provide to help, please let me know.

avatar image Sean L ♦♦ STAFF Feb 17 '16 at 02:57 PM

Hello,

I just wanted to let you know that I am currently investigating this issue, and that I will respond back with information as soon as I can.

Thank you for your patience.

avatar image iCode Feb 17 '16 at 05:57 PM

Thank you for your help. If there is anything i can do to help let me know.

avatar image Sean L ♦♦ STAFF Feb 23 '16 at 09:18 PM

I am still unable to reproduce this issue, unfortunately. How are you running your server? I am using the Run Dedicated Server option in the editor and setting the number of players to 2. Doing this, I see the scale replicating as expected.

avatar image iCode Feb 27 '16 at 01:36 AM

Interesting! When i do your setup, it works great. When i switch back the way i had it, i see the scaling issue. My setup the same as your, however, i have "New Editor Window" checked and Run as Dedicated server unchecked. Would love to know if you try it my way if you see what i am seeing.

avatar image Sean L ♦♦ STAFF Mar 01 '16 at 06:08 PM

I have tried this setup using the method you described, and I'm still seeing the cube I was using replicate its scale properly. I'm not sure exactly what we're doing differently that is allowing my setup to work and that it causing yours to behave differently. Were there any other settings that you may have altered?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I was just struggling with this problem and found my answer. For scaling, you also have to make sure that on your Mesh Component you set "Component Replicates"

more ▼

answered Jan 23 '18 at 05:38 AM

avatar image

Xilverback
146 2 9 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello,

I am marking this topic as resolved, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day

more ▼

answered Mar 07 '16 at 01:56 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 442

avatar image iCode Mar 11 '16 at 04:20 AM

understandable. I do think it is a bug, because it only happens when i have run as dedicated server off, but i cant tell you what exactly i am doing that is causing it. Thank you for your help and replies though!

avatar image formatt Apr 22 '16 at 08:13 AM

I'm having the same problem in one of my projects, haven't got any help to offer though, sorry. Just wanted to let you know that you are not alone.

avatar image Dhee9000 Apr 19 '17 at 11:17 AM

I am having this same exact issue. Has anyone found a solution to this? I am on 4.15.

avatar image Sean L ♦♦ STAFF Apr 19 '17 at 03:53 PM

Hey Dhee9000,

I have given this a shot on my end, but I'm not seeing the same behavior. Could you provide me with a detailed list of steps I can use to reproduce this on my end?

avatar image AvengerDr Apr 19 '17 at 06:00 PM

I'm having the same problem. I'm trying to display a bounding box mesh every time I press the trigger (on the Vive controller). This is the BP I'm using. The bounding box actor is set as "Replicates" and "Replicates Movement".

alt text

But as you can see, the actor is only moved but its scale is not updated. On the left you see the Server view and on the right, the client view. I got the same results with using the SetActorScale3D node individually.

Tried this with 4.15 and 4.15.1, without a dedicated server.

alt text

avatar image Sean L ♦♦ STAFF Apr 25 '17 at 02:09 PM

Unfortunately, I've attempted to reproduce the issue on my end, but I'm not seeing the same results. I've called SetActorTransform on a key press and passed in a new value for Scale, and the Scale was set properly on both the server and client.

If you can provide a simplified test project that showcases the issue using SetActorTransform, I'd be glad to take a look. It's possible that there's something I'm overlooking.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question