x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Mac OS X] libsteam_api.dylib runtime linking error

I've recently started working on compiling my project for Mac OS X and I'm having trouble getting Steam to work when launching the game.

My code attempts to call SteamApps() which gives the following error:

dyld: lazy symbol binding failed: can't resolve symbol _SteamApps in /Unreal Projects/My Game/Binaries/Mac//UE4Editor-MyGameModule.dylib because dependent dylib #3 could not be loaded

MyGameModule has "Steamworks" as a third-party private static dependency and "OnlineSubsystemSteam" as a private module dependency. It also includes the necessary Steam headers in MyGameModulePrivatePCH.h.

I'm unaware of any requirements besides copying libsteam_api.dylib into UnrealEngine/Binaries/Mac/UE4Editor.app/Contents/MacOS.

Edit: It seems that the game module is trying to load libsteam_api.dylib from /Unreal Projects/My Game/Binaries/Mac/ instead of UnrealEngine/Binaries/Mac/UE4Editor.app/Contents/MacOS. After placing the library into the game binaries directory, it loads the library fine, but calls to the Steam API fail since it hasn't been initialized. Ideally, I'd like to only use one binary.

Product Version: UE 4.10
Tags:
more ▼

asked Feb 14 '16 at 08:43 AM in Packaging & Deployment

avatar image

smaddock
51 2 3 8

avatar image Steve Hardister ♦♦ STAFF Feb 26 '16 at 06:55 PM

Hi smaddock,

It's difficult to say what is going on with your specific project but the following link may shed some light on the issue:

Dynamic Library Usage Guidelines

Please review this doc as it specifically speaks to "lazy binding." If this does not help you resolve the issue, please respond and include information about your Mac's hardware and OS.

Thanks,

Steve H.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi smaddock,

It's been a few days since we've heard back from you so we are marking this post "resolved" for tracking purposes. However, if you are continuing to get this error when trying to package, please respond with the requested information and we will continue to investigate.

Thanks,

Steve H.

more ▼

answered Mar 04 '16 at 04:26 PM

avatar image smaddock Mar 06 '16 at 09:51 PM

Hi Steve, this issue is still ongoing. However, I haven't had enough time to look into it. I'll update this post in the future when I get around to fixing it.

avatar image nah19 Mar 07 '17 at 03:17 PM

Hi Smaddock, did you solved??? I have the same issue in Mac version of my project...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question