x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

No Smoothing Group & No Triangles on Mesh While Importing FBX

I've been making a model of a railroad track in Blender and exported as an FBX to put into my game. The only problem is, I get these 2 annoying errors every time I try.

alt text

I'm not really sure why it does this, but I'm fairly new to UE4 & Blender (Transitioned from Unity and just started modeling). I've read around and searched Google, but have not reached a good answer that explains these errors. Here are my FBX export settings in Blender and import settings in UE4:

alt text alt text

and a note, my 'Plane.008' was modeled by deleting vertices of a plane, then using Ctrl+RMB to create vertices and F to merge. That may have to do with the error, as the plane has no triangles...

If anyone has any idea of how to fix this, a reply would be greatly appreciated. This is my first post and thanks in advance!

Product Version: UE 4.10
Tags:
more ▼

asked Feb 14 '16 at 10:27 PM in Using UE4

avatar image

Li357
3 1 2 3

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

When exporting, goto geometries tab and change smoothing from normals to faces. As for the triangles error I've never seen it. Unreal will auto triangulate. You could try ctrl t in blender. That will triangulate it and then export. If it doesn't work care to share the fbx? I'll give it a look over Also side note. In general I also check selected objects when exporting just in case there is any other objects in scene I forgot about when exporting, otherwise blender will export everything in the current layer you are in. If maybe possible there is a plane you deleted in edit mode but the origin is still in memory with one vertex flying around, that may cause the error because there isn't really anything there for unreal to triangulate. Maybe. Shot in the dark.

more ▼

answered Feb 14 '16 at 11:42 PM

avatar image

EyeDee10Tee
2.1k 59 14 126

avatar image Li357 Feb 15 '16 at 03:03 PM

The solution fixed the smoothing group error, but not the plane error. I just Ctrl+J joined the meshes and saved it as another file so I could go back to the unjoined to modify certain planes. Thanks!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question