x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Cannot Build C++ Project with 4.10.2

Hi,

After installing 4.10.2 and VS 2015 (several times), I am in the situation that I cannot build a simple blank C++ project. When I build in VS, I get the following output.

I'm totally stumped and could not find any info on this specific error (could not get full path for tool -q), so your help is much appreciated.

Thanks!

2> Performing full C++ include scan (building a new target) 2> [1/5] Compile test2.cpp 2> [2/5] Compile test2GameMode.cpp 2> [3/5] Compile test2.generated.cpp 2> [4/5] Compile UELinkerFixups.cpp 2>dbsbuild : error : (3b5b00de-92ce-4285-9092-6980a35928ef,26): could not get full path for tool -q 2>ERROR : UBT error : Failed to produce item: E:\UnrealProjects\test2\Binaries\Win64\test2.exe 2> Total build time: 1.99 seconds 2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(37,5): error MSB3073: The command ""D:\Program Files (x86)\Epic Games\4.10\Engine\Build\BatchFiles\Build.bat" test2 Win64 Development "E:\UnrealProjects\test2\test2.uproject" -rocket -waitmutex -2015" exited with code -1. ========== Build: 1 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Product Version: UE 4.10
Tags:
more ▼

asked Feb 15 '16 at 01:38 AM in Installation & Setup

avatar image

KyotoG
21 1 2 2

avatar image Matthew J Feb 15 '16 at 04:55 PM

Hello KyotoG,

What build configuration is your Visual Studio project attempting to build in? Did you use any previous versions of the engine/VS prior to this where you didn't have these issues? Are you using a Binary build (downloaded from the Launcher) or a source built engine? If you're using a Binary build, as a possible general fix, can you try verifying the installation through the launcher to see if it helps at all?

avatar image KyotoG Feb 15 '16 at 11:55 PM

Hi,

I tried several configs, which all gave the same error: Development, Development Editor, Game Debug, Shipping. The above error is from the Development config.

I installed 4.10 first (but only tried blueprint projects, which worked fine both on 4.10 and 4.10.2). A few days later, 4.10.2 was released so I installed that.

I'm using the Binary build, so I'll take you advice and try verifying and will post my results soon.

Thanks!

avatar image KyotoG Feb 16 '16 at 12:10 AM

I reinstalled, and unfortunately get the same issue as before. This is the output when generating the project from the New Projects tab of the project browser.

The project could not be compiled. Would you like to open it in Visual Studio?

Running D:/Program Files (x86)/Epic Games/4.10/Engine/Binaries/DotNET/UnrealBuildTool.exe test3 Development Win64 -project="E:/UnrealProjects/test3/test3.uproject" -rocket -editorrecompile -progress -noubtmakefiles -2015 @progress push 5% Parsing headers for test3Editor Running UnrealHeaderTool "E:/UnrealProjects/test3/test3.uproject" "E:\UnrealProjects\test3\Intermediate\Build\Win64\test3Editor\Development\UnrealHeaderTool.manifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -rocket -installed Reflection code generated for test3Editor in 6.978961 seconds @progress pop [1/7] Resource PCLaunch.rc [2/7] Resource ModuleVersionResource.rc.inl dbsbuild: error: (ef15ceb5-927a-4bf2-8b43-abd61a98884e,5): could not get full path for tool -q ERROR: UBT ERROR: Failed to produce item: E:\UnrealProjects\test3\Binaries\Win64\UE4Editor-test3.dll Total build time: 16.83 seconds

avatar image KyotoG Feb 16 '16 at 02:56 AM

I went ahead and tried to build the Unreal Engine myself (from GitHub) and I get the same error. "could not get full path for tool -q" What is the build looking for? Is there a way of getting a more verbose output so I can try and track down what the actual issue is?

11>dbsbuild : error : (ef15ceb5-927a-4bf2-8b43-abd61a98884e,7): could not get full path for tool -q 11>ERROR : UBT error : Failed to produce item: E:\UnrealEngine\Engine\Binaries\Win64\ShaderCompileWorker-Core.dll

avatar image KyotoG Feb 16 '16 at 04:01 AM

I found this thread, which points to SN-DBS being the problem. I'll first try upgrading, and if that fails, uninstalling it.

https://answers.unrealengine.com/questions/309594/visual-studio-2013-pro-cant-compile-dll.html?sort=oldest

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I couldn't upgrade SN-DBS as this would affect everyone in our company, but uninstalling solved the issue.

more ▼

answered Feb 16 '16 at 04:29 AM

avatar image

KyotoG
21 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question