x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.10 Can't Package

I have here in my pc versions 4.9.2 and 4.10.2 I made a project on my 4.10.2 version and it does not package, no idea why, i thought i had some problem on my project but i made some tests with the main project and they do not package too. If i create a third person / top down or any new project, when i try to package it gives me error. Also when i open a project on 4.9.2 it works.

I tried to update my visualstudio 2015 and 2013 and nothing, also i tried to uninstall ue4 version and installed again but same problem, package function does not work.

Here is my output log, i dont have much knowledge about C++, since i work mainly with blueprints, so would be very nice if someone could help.

link text

Product Version: UE 4.10
Tags:
output log.txt (30.1 kB)
more ▼

asked Feb 15 '16 at 09:00 PM in Packaging & Deployment

avatar image

iorek01
61 1 3 7

avatar image Matthew J Feb 15 '16 at 09:33 PM

Hello iorek01,

From looking at the log, it seems like the compilation part of the packaging is what is failing. Could you try opening up the Visual Studio .sln for the project and compiling in Development Editor to ensure that it is compiling correctly? Also, what platform (such as Windows or Android) are you attempting to package for?

avatar image iorek01 Feb 15 '16 at 09:48 PM

Hello Matthew,

im trying to package to windows, well im really not sure what file is .sln?(looking for doc it says i need to open a bat file, not sure where is this file) when i open my project folder i found only the uproject file and folders, etc

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The project should be a code project if the packaging process is trying to compile. As part of that list of folders, is one of them titled "Source"? If so, then this is a code project. That means you'll need to right-click the .uproject file and select "Generate Visual Studio project files". This will create the .sln file which can be opened with Visual Studio.

more ▼

answered Feb 15 '16 at 09:54 PM

avatar image iorek01 Feb 15 '16 at 09:56 PM

I tried to generate the project files but this is what happens.

alt text

error.png (17.8 kB)
avatar image iorek01 Feb 16 '16 at 01:42 AM

I was able to fix. I updated my visual studio 2015 again, then i generated the visual studio project inside the editor so it updated the code and generated the file you were talking about, then i was able to package projects on 4.10.2. Thank You for your time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question