x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

SmartLink property changes do not take effect until "Smart Link Is Relevant" has been toggled

Any change to Link Relative Start, Link Relative End, and Link Direction will not be visualized nor will the link and navmesh be updated until "Smart Link Is Relevant" has been toggled off then on again.

Product Version: UE 4.11 Preview
Tags:
more ▼

asked Feb 16 '16 at 08:51 PM in Bug Reports

avatar image

KGist
106 2 14 23

avatar image Rudy Q ♦♦ STAFF Feb 16 '16 at 09:49 PM

Hello KGist,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?

  3. Could you provide screen shots that may be relevant to this issue?

avatar image KGist Feb 17 '16 at 04:27 PM

Hi Rudy,

The simplest way that I've found to reproduce this is to do the following: 1) Create a new project 2) Add floor, NavMeshBounds, and NavLinkProxy 3.) Enable "Smart Link Is Relevant" on the NavLinkProxy. Note that the navmesh is visually updated. 4.) Save the project and close it

Then, each time the editor is opened, I see the following sequence: 1) Modifying the SmartLink property once does not appear to update the link 2) Subsequent updates may cause the SmartLink to disappear entirely 3) Toggling SmartLinkIsRelevant off and on again brings the SmartLink visuals back and seems to cause the SmartLink to begin updating consistently.

I believe I have seen situations where the SmartLink doesn't seem begin updating consistently even after the toggle, but I don't have a clear repro for that.

Thanks, -Kelson

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

After doing a bit more digging I was able to find that this appears to be a known issue (UE-22634) that has been reported and sent to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

more ▼

answered Feb 18 '16 at 06:11 PM

avatar image

Rudy Q ♦♦ STAFF
47.9k 544 132 522

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question