x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is the player start position above the actual actor position on the Vive?

Hi,

Just getting into VR. I've built a simple room (4 walls, ceiling and a floor and placed a player start actor, surprise surprise on the floor. As expected, this works fine on Desktop and Occulus Rift.

However when a friend tried the same level on the HTC Vive, the start position was in the ceiling, even though the original actor was on the floor. Any ideas what might be causing this and if so, is there a fix?

Many thanks

Product Version: UE 4.10
Tags:
more ▼

asked Feb 17 '16 at 02:54 PM in VR

avatar image

McGen
21 1 1 3

avatar image junjie020 Apr 21 '16 at 01:43 AM

same problem with this. Did you find out what the problem is ?

avatar image Drakenator May 24 '16 at 06:39 PM

I am experiencing the same issue but 2 different ways depending on movement style...

  1. If I use teleportation through the use of line tracing, the player starts about 2 feet too tall until the first teleport. All is good after that.

  2. If I use a thumbpad form of translation, the player starts at the right height but then jumps to being too tall once movement starts.

These are 2 different scenes and cameras are locked to HMD and set to 0. I'm wondering if it might not be a Steam issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

You have to set the player at 0 for the y also make sure you have the eye position set to 0

more ▼

answered Apr 21 '16 at 02:38 PM

avatar image

heith
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I found a solution to this problem on the node where Unreal sets the VR pawn height depending on the various platforms. If you are using a Player Start to setup the initial player position, I had the issue that the player would always spawn around 60 cm too high. Changing the eye height had no effect whatsoever. What I did was reroute the default option for SteamVR to Eye Level instead of Floor level, and then in the successive node I changed the "Default Player Height" to -60, therefore compensating the error.!

more ▼

answered May 03 '17 at 02:36 PM

avatar image

DAck Games
30 2 3 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question