x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Drag and Drop widget error - hotbar becoming corrupt

I posted about a previous occurrence of this error (last year in an entirely different project) but no fix was presented then and I abandoned that thread thinking that there was simply some glitch in my system.

However, it has re-occurred in a quite nearly identical circumstance -- with a drag and drop hotbar. This is an entirely new project with no common blueprints or code with the first.

A hot bar widget has become corrupted and I am unable to repair the error. Each time I close the editor, changes to the widget fail to save or become corrupted in the exact same fashion.

Demonstrated in this video: https://www.youtube.com/watch?v=Wy_qrCf3gAw

Product Version: UE 4.10
Tags:
more ▼

asked Feb 17 '16 at 06:36 PM in Bug Reports

avatar image

Rhynedahll
21 3 4 8

avatar image Rudy Q ♦♦ STAFF Feb 17 '16 at 07:41 PM

Hello Rhynedahll,

While the video helps in some regards there was not enough information to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps to help reproduce this issue on our end?

  3. Could you provide a screen shot of all blueprints that may be involved in this issue?

avatar image Rhynedahll Feb 17 '16 at 08:38 PM
  1. The project is as clean as it can be. It only has the ARPGIS (which I have not modified) from the Marketplace and free Market content. My own code/blueprints are minor and do not interact with the HUD or the individual widgets. And, of course, the error would not occur in a project without complex nested widgets.

  2. As on the previous occasion, this corruption simply occurred unnoticed at some point and was only detected when I realized that the hotbar was not present..

  3. I do not believe it to be a blueprint issue. All of the blueprints involved are in the ARPGInventorySystem, which is available from the Marketplace. A fresh migration of the ARPGIS content does not contain this issue.

The individual widgets involved all appear to be in proper shape. It is possible to add a new hotbar to the layout and when this is done, it appears to be correct. The layout compiles and saves without error or at least appears to do so. However, the changes do not take or save to disk and there is no indication from the editor that an error occurred.. The hotbar is actually still present but apparently empty and thus not visible when playing the game.

I have manually overwritten the offending assets from a fresh project, but the error is still present.

avatar image Rhynedahll Feb 17 '16 at 09:34 PM

After digging in more, I was able to recreate the problem in a new project simply by playing as a standalone game. The hotbar is present when playing in the editor.

However, the widget layout does not appear corrupted.

avatar image Rudy Q ♦♦ STAFF Feb 18 '16 at 02:30 PM

When you say that you were able to reproduce this issue in a clean project, does this mean you were able to do so with no additional content(nothing outside of starter content)? If so, could you provide the steps (in detail) that you used to recreate the issue in a clean project?

avatar image Rhynedahll Feb 18 '16 at 04:08 PM

As the error occurs with nested widgets, a project without content is not capable of having the error and therefore your question is not cogent.

avatar image Rudy Q ♦♦ STAFF Feb 18 '16 at 08:03 PM

I may not have been clear before and I can see how that may have caused some confusion, what I meant by "Reproducing this in a clean project" was that I would like for you to start with a new project and recreate the asset that you are having issues with. This would mean recreating the widget that has the nested widgets. This process helps eliminate any extraneous variables.

avatar image Rhynedahll Feb 19 '16 at 12:56 PM

I did some work on this yesterday, but the editor consistently crashed at a particular point. I will try again this weekend.

avatar image Rudy Q ♦♦ STAFF Feb 19 '16 at 06:59 PM

Thank you for taking another look into this issue's reproduction I will be happy to assist you further once you have more information. As far as the crash that you are experiencing goes, you could create another thread (for tracking purposes) and post a link in a reply here and will take a look.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello Rhynedahll,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Feb 24 '16 at 08:57 PM

avatar image

Rudy Q ♦♦ STAFF
47.7k 545 132 522

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question