x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Setting Auto Destroy When Finished Not working

Hello, on my current project, I'm using "Destroy Actor" to well...destroy enemies, projectiles, dead players, etc.

Yet I keep getting that "PIE:Error: Error Cannot access ''. It is pending kill. Property: '' from node Branch in graph '' in blueprint " error. To counter this, some posts I read suggested setting the actors' auto destroy when finished variable to true so the engine could perform a clean destruction.

Unfortunately, that does not seem to be working. The actors are not being destroyed. I suspected the reason could be because something kept accessing the to-be-destroyed actor however, I also tried setting that variable on an empty actor, during its being play event, to no avail.

Is this a bug? Do I need to have additional considerations when using this method?

Thank you in advance.

PS: I checked the engine's source code to see if there was something particularly weird regarding this variable but I haven't noticed anything...

Product Version: UE 4.10
Tags:
more ▼

asked Feb 17 '16 at 07:57 PM in Blueprint Scripting

avatar image

e-vinyl
31 1 3 6

avatar image e-vinyl Mar 19 '16 at 11:43 AM

still having this problem

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi guy, I know it has been a lot of time as you asked but I had the same problem just right now and as a workaround solved it with a delay. (I am working in version 4.21.2)

Here is example in BP: alt text

If not you I hope it helps someone else.

destroydelay.png (82.4 kB)
more ▼

answered Apr 05 '19 at 10:20 AM

avatar image

zaguarman
3 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question