x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Linux - Project Files not generating

So, before, this always worked:

$ ./GenerateProjectFiles.sh /path/to/project/

but now, although it says it's generating everything, not a single file appears in my project folder!
Of course I cannot compile and load it up now, so... what do I do to fix this?

I'm on Manjaro and use UE4's "release" branch from github.

Product Version: UE 4.11 Preview
Tags:
more ▼

asked Feb 18 '16 at 09:29 AM in Linux

avatar image

CAPTNCAPS
148 31 24 31

avatar image HeavenlyGamesBoss Feb 18 '16 at 10:07 AM

I think there is a way to create and check logs to see if the software is actually generating the files. You could do that or do a search on your compile output and see from there. Maybe you could just put this in the folder your building your project in instead of putting it in an out of build folder. I would also check your permissions in the out-of-build folder you're trying to put your project files into. You may not have permission to do it. This would explain why it says its generating files but not actually going into them.

avatar image CAPTNCAPS Feb 18 '16 at 10:13 AM

Permissions are fine, but what do you mean with out-of-build folder?
The GenerateProjectFiles.sh must be located and run in the UnrealEngine folder, and my Project is just in the default path UE4 creates projects in.
I'll check that log idea.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You can use UnrealBuildTool (UBT) manually.

I assume you are on Gnux (GNU/Linux) but is the same on Mac and Windows of course:

mono Engine/Binaries/DotNET/UnrealBuildTool.exe -makefile -project="..../*.uproject" -game -engine

Replace -makefile, either with: -codelitefile, -kdevelopfile, -qmakefile. whichever you want to use. The arguments -game and -engine tells UBT to create the game targets and the engine targets. If you don't need the engine targets don't use it.

more ▼

answered Feb 19 '16 at 04:31 AM

avatar image

Yaakuro
314 13 7 19

avatar image CAPTNCAPS Feb 19 '16 at 09:43 AM

Omg, thank you! This works now!

avatar image HeavenlyGamesBoss Apr 20 '17 at 09:54 AM

Hey Yaakuro. I'm having a lot of issues with my projects crashing during build and not being able to relaunch them no matter what I do with the C++ code. I'm thinking that the editor is holding onto some kind of file that is making it crash. No matter how many times I try to clean and rebuild my project, the editor crashes when I select to work on it after a segfault.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question