x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Character Yaw input issue

Hello,

I am attempting to implement a method of varying the rotation of a third person character dependent upon W,A,S,D. Currently, W/S successfully modify the roll of my character whilst A/D succesfully changes the pitch through the use of an "AddLocalRotation" block. However, regardless of the value I input to the "Yaw" value no Yaw rotation occurs. Instead, my character appears to "flicker" from side-to-side (as it attempts to reach the positive and negative values of the float input in the same Tick). As far as I can tell there is no scripted reason for this behaviour. Is there something I am missing?

Product Version: UE 4.9
Tags:
more ▼

asked Feb 18 '16 at 12:28 PM in Blueprint Scripting

avatar image

Brock Lee
8 3 5 7

avatar image Mopperl Feb 18 '16 at 12:44 PM

Not entirely sure but often times rotation can be screwed with by the Pawn using the control rotation (camera) for yaw value or the Character using orient rotation to movement(If it does have a character movement component), did you check on if it may be one of those two?

avatar image Brock Lee Feb 18 '16 at 12:48 PM

Yes, I have checked that the pawn is not using the control yaw rotation and the character is not using orient rotation to movement. Thank you for your suggestions though.

avatar image Brock Lee Feb 18 '16 at 01:51 PM

I believe the exact same issue was found by another user here, however no solution has been accepted in this instance either:

https://forums.unrealengine.com/showthread.php?80156-can-t-Yaw-but-can-pitch-and-roll

avatar image Mopperl Feb 18 '16 at 02:13 PM

alt text

I've slapped these into the regular third person BP project and it rotates him in the desired directions with either world or local rot just fine, maybe you could put a screenshot of your BP?

rotation.png (219.9 kB)
avatar image Brock Lee Feb 18 '16 at 02:42 PM

Here is the rotation seection of my blueprint; the code not included here is initialization code (which upon EventBeginPlay sets rotation and velocity of 'Mesh' to zero) and "InputAxis MoveForward" + "InputAxis MoveRight". These are not included as they are assigned to "Current Pitch Speed" and "Curent Roll Speed" respectively to make the blueprint neater. 'Mesh' is a Skeletal Mesh Component Reference to the Third Person Character Skeletal Mesh Component "Mesh"; this represents the character.

EDIT: The 'R Pressed' Event is currently being used to test rotation by incrementing the rotation by a set amount

[1]: /storage/temp/78985-rotation+specification.png

avatar image Mopperl Feb 19 '16 at 08:11 AM

I've tried reproducing that and it worked for me to rotate the mesh with those nodes hopefully someone else has an idea whats going on. My only suggestion would be trying to make a blank test object and start with rotating then add the other functionality gradually to see which step might cause it, or possibly simply an engine related bug in wich case you should poke a staff member about it.

avatar image Brock Lee Feb 23 '16 at 10:16 AM

I have spent the past few days working on this but have not managed to alleviate the issue. As a last resort I reinstalled Unreal 4.9, remade my project and now the exact same blueprint works without issue. I am not sure what caused this error or how it was resolved, but I shall not question it at this moment in time. Apologies I cannot be more helpful in resolving this issue.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

You can try uncheck "Use Controller Rotation Yaw" in Class Deafults of your Character.alt text

more ▼

answered Apr 08 '16 at 09:34 PM

avatar image

Aidmus
36 2 3 4

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question