x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

GearVR stereo cubemap severe aliasing

Hello, I hope someone can help because I have run into a problem with UE4 GearVR rendering.

I have set up UE4 for displaying stereoscopic cubemaps with the GearVR (+Samsung S6). But the result rendered with Unreal Engine is not sharp enough and suffers from severe aliasing of edges in the image. The same cubemaps in Otoy's ORBX viewer render very crisp with no aliasing. I have tried a lot of settings to fix this but nothing has worked (multiple types of anti-aliasing, mipmaps, screenpercentage, etc.).

The stereo cubemaps are converted to .dds via Photoshop and rendered on a sky box with a material that samples the left and right cubemap depending on the screen side. The camera world position is used as UVs.

Does anyone know a fix for this?

Or is this the result from UE4 rendering at a fixed 1024x1024 per eye for the GearVR?

Product Version: UE 4.10
Tags:
more ▼

asked Feb 18 '16 at 01:18 PM in VR

avatar image

MeessenPhilips
13 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

What material setup are you using? I'm facing similar issues even with monoscopic 360 images. Did you find any mean to increase the quality and fix the aliasing?

more ▼

answered Mar 03 '16 at 12:16 AM

avatar image

devel.bmad
439 43 49 65

avatar image MeessenPhilips Mar 03 '16 at 08:31 AM

I did not manage to fix it yet. Unity doesn't have this problem, so we are likely going with that instead.

avatar image devel.bmad Mar 04 '16 at 09:59 AM

Yes I see, I'm considering the same. Where did you get the info that UE4 is rendering 1024x1024 on GearVR?

avatar image devel.bmad Mar 05 '16 at 10:24 PM

This should help, not much for the quality of the sampling, but for the overall resolution. Try setting MobileContentScaleFactor to 0, it worked for me: https://forums.oculus.com/viewtopic.php?t=26708

avatar image MeessenPhilips Mar 07 '16 at 08:41 AM

Thanks but I already tried that and it didn't work.

The 1024 is mentioned in several posts if you search for it. But I don't think its the cause of this problem.

avatar image devel.bmad Mar 07 '16 at 04:44 PM

Try changing directly BaseDeviceProfiles.ini in the config folder of the engine, instead of the one in your project, build, run and then check with the command: adb logcat -d -s UE4 > log You should be able to see the actual resolution used, should be 2560x1440 (tip: search for 1440 in the log)

This fixed the resolution problem for me (without this you are rendering at 1/2 the real resolution), this is a screenshot of my output alt text

The aliasing could be probably solved enabling MIP mapping, but I'm not sure which are the right settings. Disabling MIP mapping improves the general sharpness.

Also: not sure how MSAA works, but it doesn't seem to fix the aliasing of the textures (just the edges of the polygons). Any idea?

avatar image MeessenPhilips Mar 08 '16 at 02:32 PM

Where do you run the command? Via the windows command line or UE4 console? as both don't output anything. Are you deploying wirelessly?

I think the mipmaps are blurry because UE4 can only properly generate them for power of two images, as those are sharp, non power of two aren't. You can generate better (non blurry) mipmaps in Photoshop when exporting to .dds, but that didn't seem to have any effect in unreal engine.

Anti-aliasing doesn't seem to effect anything (apart from temporal AA, which breaks the VR rendering).

It is annoying that both Unity and UE4 can't easily render this properly. (Unity has no aliasing but is a bit blurry)

avatar image devel.bmad Mar 08 '16 at 10:19 PM

I deploy using an usb cable, setting the gear VR in developer mode Once you set MobileContentScaleFactor to 0 the quality is not that bad, I've compared the screenshot from 360 photos and this one and while the UE4 is a tad less sharp, and has aliasing problems if you don't use mipmaps, they are more or less in the same ballpark.

The best solution I've found so far is to use mipmaps and a mid level sharpen on the textures.

avatar image devel.bmad Mar 08 '16 at 10:29 PM

Also, 4.11 may improve things with OVROverlays support, but haven't found much info about this yet

avatar image so2gamemake Jul 04 '16 at 06:00 AM

Nice scenery! Got a link to your project?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question