x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UProject solution generation problem with Vulkan API

Hello,

After i've downloaded Vulkan API and installed it on my PC, i cannot generate visual studio project files. This error shows up :

alt text

I've tried to uninstall Vulkan API, but it did not helped. Any ideas on what could be the problem ?

Product Version: UE 4.9
Tags:
vulkanerror.png (37.1 kB)
more ▼

asked Feb 19 '16 at 10:12 AM in Installation & Setup

avatar image

Arch1eN
6 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This error comes from MissingModuleException.

Checking the build system this comes from an environmental variable:

 string VulkanSDKPath = Environment.GetEnvironmentVariable("VK_SDK_PATH");

Do you know how to check environment variables? Looks like you're using windows. One way is a command window and type

 set VK_SDK_PATH

Can you check at that folder that it's not empty? Maybe it's in a new location? Kinda guessing here as I've never played with this.

more ▼

answered Feb 19 '16 at 10:44 AM

avatar image

Bino
269 9 5 13

avatar image Arch1eN Feb 19 '16 at 11:05 AM

Hey, thanks for a quick answer :)

  1. I checked the env variables, there is no sign of anything related to Vulkan (Yes its Windows 7).

  2. What folder ?

Also, i've removed Vulkan from my PC, project launching is more important, however its remaining's are preventing me from making source files (and making a successful build). Do you know perhaps what should be done to remove those remainings ?

avatar image Bino Feb 19 '16 at 11:19 AM

No worries,I just picked something randomly :P

The environment variable points to a folder.

However I realised I wasn't checking the code from your version.

In UEBuildWindows.cs is commented out:

 /*                        
          if ((!String.IsNullOrEmpty(VulkanSDKPath)))
          {
                     Rules.DynamicallyLoadedModuleNames.Add("VulkanShaderFormat");
          }
 *

Can you check if that's the case for you? Other than that... I'm not too sure.

I'd be curious to see the rest of your command line arguments from your screenshot.

EDIT: sorry didn't reply, I'm new to answer hub :P

avatar image Arch1eN Feb 20 '16 at 06:00 AM

Hey.

Problem solved, but in a very weird way, i've just copied and pasted the engine from to another drive, and back, and it worked :P. Though if anyone will have the similar issue, i recommend to try Bino's solution.

By the way, thanks for your help :)

avatar image Bino Feb 20 '16 at 08:48 AM

I guess when in doubt re-install always works!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question