x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Package for multiple Gear VR headsets?

Hello.

Me and a friend have been working on a UE4 project. I have been able to successfully deploy the Android package on my note 4 and his note 6S. However, when I package for deployment with the Gear VR headset enabled as well, I am only having success on my Note 4 and not his Note 6S. I have followed every step correctly that I know of, including adding the other phone and headsets osig file. There are two things that I am not 100% certain on, but I think I did correctly, which are, downloading the correct drivers for the phone from Samsung download page and needing the RSA fingerprint key. Are either of these important information to have if I am not launching on his device, only packaging for it? It would seem weird to me if this was the problem because the non-VR package works on his device. The last thing I may have not considered is that he lives in the Netherlands and I am in the US; do I need to add something for this to work there? I know I haven't given a ton of information, but I don't know what other facts you should need, please let me know if there is anything I can provide.

Both on my phone and his, when the VR app is clicked to start, it gives the proper insert to gear vr headset notice. When I insert, in about 5-10 seconds, the app will begin. However, when he inserts, within 10-15 secs, the app will NOT start and the Oculus Store home page will appear...

Anyways, if you have any thoughts, I am open to trying them, we have been trying to develop this for a long time and want to get past this step. Any and all help and suggestions are greatly appreciated!!!!

Thanks a lot, Brad

Product Version: UE 4.8
Tags:
more ▼

asked Feb 22 '16 at 12:19 AM in Packaging & Deployment

avatar image

Bamwd5
128 11 14 19

avatar image Samantha Sutton ♦♦ STAFF Feb 29 '16 at 08:18 PM

Hey Bamwd5,

In order to better assist you, I need to figure out a few things. First of all, there is not a Note 6s. The highest Note there is, is the Note 5. Are you on the Samsung Galaxy 6s or the Samsung Galaxy Note 5? Which version of android is each of the devices tested on? Could you please provide me with the logs from your device you're having trouble with? If you're not sure how to get logs off of your Android device all you need to do is follow these steps:

  • Go to C:\NVPACK\android-sdk-windows\tools

  • Run Monitor.bat

  • Copy all of the logs and save them to a notepad

Thanks!

avatar image Bamwd5 Feb 29 '16 at 08:48 PM

Hey Samantha

Thanks for the help! Sorry for the confusion, the two phones are a Note 4 and a Galaxy 6s. The application is currently working on the Note 4 which is running on android version 5.1.1 in the USA. The application does not work on the galaxy 6s which is running on android version 5.1.1 in the Netherlands. I do not have the device in person that the app is NOT working on. I will try to get the logs from my friend tomorrow. I hope this info helps for now!

Thanks a lot, Brad

avatar image Bamwd5 Mar 01 '16 at 04:40 PM

Hey Samantha.

Thanks again. Attached is the log from the Galaxy 6s in the Netherlands. Let me know if there is anything else I can assist with.

Thanks, Bradlink text

log.txt (631.4 kB)
avatar image Samantha Sutton ♦♦ STAFF Mar 01 '16 at 07:30 PM

The Gear VR 2 (the new one) only works with the Galaxy S6, Galaxy S6 edge, Note 5 and Galaxy S6 edge+. The (older) Gear VR works with the Samsung Galaxy Note 4. I believe that's the issue you're running in to.

avatar image Bamwd5 Mar 01 '16 at 07:32 PM

Ok. Is there a different way that I have to package for the Gear VR 2? Or extra installation process that I have not yet done?

To clarify, my Note 4 and Gear VR are working correctly in the US. My friends Galaxy S6 and his Gear VR 2 are not working; when the app is started it remains black and then loads the Oculus home page.

Thanks.

avatar image Samantha Sutton ♦♦ STAFF Mar 01 '16 at 08:41 PM

You should have your friend contact us since it's not something that's happening to you directly. However, I would suggest passing these links along to your friend:

avatar image Bamwd5 Mar 01 '16 at 08:44 PM

Ok, I can pass those along. But having him contact you probably wouldn't help much as I am doing all of the Unreal work and packaging myself and then sending to him for him to install and try. It just seems weird that it is working for me and I send the exact same package to him (with his osig as well) and it doesn't work.

If you can think of anything else for me to check or try, I would really appreciate it.

Thanks, Brad

avatar image Samantha Sutton ♦♦ STAFF Mar 02 '16 at 03:23 PM

Brad,

I would suggest trying a sample project in 4.9, 4.10 and 4.11 preview and send those over to your friend to test on his device while you test on yours. Make sure that you're disabling the plugin for 'Oculus Rift'. I could not find that plugin in version 4.8 which you placed in your initial post, so maybe that's part of the issue you're running in to too.

Let me know what you discover during investigation. :)

avatar image Bamwd5 Mar 02 '16 at 03:42 PM

That would be a good test. I'll try that, thanks.

In the current project we are discussing, I have enabled the Gear VR plugin and disabled the Oculus plugin. This project is in version 4.8. That is interesting that you cannot find the plugin in 4.8, I have developed other gear vr and oculus projects on this version. But hopefully your advice for the higher version tests will work! I will try today and keep you updated.

Thanks, Brad

avatar image Samantha Sutton ♦♦ STAFF Mar 02 '16 at 09:06 PM

Just keep me updated, thank you. :)

avatar image Bamwd5 Mar 07 '16 at 07:45 PM

Hey Samantha:

I have not gotten word back on the test projects. I have been able to send him a 4.8, 4.9 and 4.10 version of the fps for Gear VR for him to test to see if they work on his s6 and Gear VR 2 headset.

I did think of a question in the meantime. I have not updated any sdk or oculus runtime files since I have been using the original Gear VR and Note 4 and the Oculus DK2 headset. Could this be an issue for the new Gear VR 2 headset?

I have the 0.8.0.0 Oculus SDK and my Android SDK Manager does show (4) updates for tools, platform-tools, platform (rev 3), and support library. Image attached.alt text

Thanks, Brad

capture.jpg (238.1 kB)
avatar image Samantha Sutton ♦♦ STAFF Mar 08 '16 at 09:36 PM

Brad,

Please verify that you've gotten the Oculus Signature File (osig) file by going here. By going to the link provided, you can generate your file and log in with your account once you've created on.

If you already have this set up, please disregard but make sure to verify whether or not your friend also has this.

Thanks!

avatar image Bamwd5 Mar 08 '16 at 10:13 PM

Samanatha:

Yes, I have definitely created an osig for my device and have deployed successfully to it, development and distributed. I have also had my friend complete the same process and have included his osig file onto my computer in the same location as mine for packaging.

I also have checked the completed package apk and both osig files are within.

But thank you for checking! I wouldn't be surprised if there is an obvious thing I am just messing up. Any other suggestions are welcome!

But, after all this testing and updating, I have to assume that there is a difference in development for the Gear VR (for note 4) and the Gear VR 2 (for note 5 and galaxy devices)...

We will get it and are getting closer.

Thanks, Brad

avatar image Samantha Sutton ♦♦ STAFF Mar 09 '16 at 03:12 PM

Has your friend reached out to you regarding the test projects that you provided? Could you please check with him and see whether or not he is on the same SDK settings as you are?

avatar image Bamwd5 Mar 09 '16 at 03:22 PM

Hey Samantha:

I just heard back from him now. The tests did not work... That was a test from each version of UE4. But you may be on to something with SDK settings. When you say, make sure they are the same, do you mean file locations? (Example: C:/NVPack/.....etc)

I have had to modify the batch file for the correct location of these files as they are stored in a different location. But through changing the batch we have successfully deployed the non-vr app on his device. It is only the gear vr that is not running successfully.

Thanks, Brad

avatar image Samantha Sutton ♦♦ STAFF Mar 09 '16 at 05:15 PM

Brad,

I've spoken with our developers and with the logs that you did provide a while back, we didn't see any UE4 movement in them. UE4 would show up in the logs or they're expected to if the game is launched on the device. If your friend has the proper Osig file, then it should be working no problem.

avatar image Bamwd5 Mar 09 '16 at 05:28 PM

Samantha:

Thanks for checking the logs again. Could the UE4 not showing up be a problem with transferring the packaged data via dropbox?

I had another friend test the project on his headset (Gear VR 2) also in the Netherlands and it worked, however the latency was worse on his than mine which was weird.

I will have my friend regenerate an osig on the developer site and we will start fresh.

I'll let you know! Thanks, Brad

avatar image Bamwd5 Mar 09 '16 at 05:50 PM

Another thought in reference to his osig file. He has followed the first two steps of the Android setup ue4 documentation and the Gear VR setup documentation. However, he does not have UE4 on his computer that he is installing the packages I am sending him. So therefore, his osig file is not in any specific folder, such as (\engine\build\android\java\assets) because it does not exist on his machine. In my mind this shouldn't be a problem, but is it?

Does he need to have UE4 installed on the machine that he is installing the bat file from, just so that it can locate the osig?

Much like how he had to install the Android SDK and change the paths in the bat to point to his unique file location.

Thanks, Brad

avatar image Samantha Sutton ♦♦ STAFF Mar 09 '16 at 07:47 PM

Are you packaging your project in distribution for shipping or is it in development because you're testing? That might be causing part of the issue. You should be able to use a packaged project without having the Editor however, it's possible you might be missing some files to provide to him which have pre-requisites in it.

Ask him to run through the Android SDK settings again for AndroidWorks and also make sure he has everything set up appropriately for the Gear VR 2 and the Samsung S6 that he's using.

UE4 Documentation: Packaging Projects UE4 Documentation: Running Unreal Engine 4

avatar image Bamwd5 Mar 09 '16 at 08:13 PM

This is currently a test project that I am sending him as a development package. I am sending all files that come in the package (apk, bat, and obb).

The Android SDK settings should be setup properly because we have had a successful android development package install, it is only the gear vr 2 that we have not gotten to work. But it is worth him reinstalling or updating as well.

As for the Gear VR 2 setup and Samsung S6 setup. I believe he has followed the documentation up until installing UE4 and saving the Osig file in the engine folder because there is no engine folder because he has not downloaded UE4.

Otherwise, the only pre-reqs seem to be the Android SDK and the correct USB drivers for his phone (which again, I think he has because he has successfully installed the android only non-vr development package.)

Is there a way to check the bat file for what is required for him to have installed? Or a way to check his logs as to whats not being installed that must be?

Thanks, Brad

avatar image Samantha Sutton ♦♦ STAFF Mar 10 '16 at 05:40 PM

Could you please make sure that your friend has plugged in the Android device and accepted the fingerprint of the computer on his device? Once he's done that, install the application onto the device and run it. If it does not work correctly, close it all out and then open Monitor.bat on the computer. While the device is connected to the computer, capture the logs from trying to run the application once again. Then make sure that he selects all of the logs. I'd also suggest adding in a filter for UE4. When you reply back, please provide his full logs and the UE4 logs he got from Monitor.bat and make sure they're uploaded separately in .txt format.

Hopefully this captures what we need this time. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Samantha:

I received great news today! We have been able to successfully deploy this project on his Gear VR 2. Thank you for all of your help.

After you brought up the basic idea of the osig process not being done correctly, I made sure to re-send him the documentation for completing this process. This time, we went through it together and the process worked!

The osig file had a different ID, so it seems the wrong ID was used the first time when trying to develop the osig. I think this was due to him trying to check the device id with a mac instead of a windows computer.

Anyways thanks for guiding us to the correct, basic solution!!

Your help was greatly appreciated.

Brad

more ▼

answered Mar 10 '16 at 05:53 PM

avatar image

Bamwd5
128 11 14 19

avatar image Samantha Sutton ♦♦ STAFF Mar 10 '16 at 07:11 PM

You're very welcome! Good luck to you both!

avatar image Bamwd5 Mar 10 '16 at 07:16 PM

Thanks Samantha!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question