x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to prevent inverted bone on import from blender

I'm getting a weird issue with a single bone on my animations when I import from Blender. One of the bones is being inverted, which is causing the tail to poke through the body. The still model looks fine and the other animation doesn't have this issue. It's only a problem on one aniamtion. I'm a noob and have no clue what the issue might be, but I'm inclined to think that I am just doing something wrong. Anybody know what the solution to this problem might be? Images and warnings I get on import are below.

alt text

Blockquote

Warnings On Import

Warning Warning: No smoothing group information was found in this FBX scene. Please make sure to enable the 'Export Smoothing Groups' option in the FBX Exporter plug-in before exporting the file. Even for tools that don't support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing. Warning Mesh 'Sphere' has no UV set. Creating a default set.

Product Version: UE 4.10
Tags:
inverted_bone.jpg (103.6 kB)
more ▼

asked Feb 22 '16 at 07:52 AM in Everything Else

avatar image

dogyear
1 2 2

avatar image dogyear Feb 22 '16 at 08:08 AM

Man... I literally spend all day on this issue and I finally decide to post a question only to figure out the fix moments after doing so. It turns out that the bone that was being inverted had a -180 roll on it. I just set it's roll to 0 and re-imported the mesh and the animation is working just fine TT_TT

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The smoothing is a common problem because blenders default smoothing option is normals but you want faces because unreal doesn't care about normals. So when exporting depending on which version of blender you are using. Old blender under scale is smoothing option, it'll sany normals, change to faces.

more ▼

answered Feb 22 '16 at 09:58 PM

avatar image

EyeDee10Tee
2.1k 59 14 126

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question