x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Android: External Login UI Doesn't Appear

Hello, I've been working on a 2D Unreal 4 Game for Android, that I want to have Google Play support, mostly just for Achievements and Leaderboards. I believe I have everything set up properly, see screenshots below, but it seems no matter what I try, I can't get the Show External Login UI, to actually bring up the Login UI. It just immediatly goes to the On Failure path. It doesn't freeze, or crash the game, like I've heard was a common problem if you don't put the AppID in the GooglePlayAppID.xml file. And I've looked over AndroidManifest.xml and proguard-project.txt as well, but I'm not sure what to look for, in case anything is wrong. My game only uses blueprints, so there's no Build.cs file, or not one that I could find. And I've even tried to get logcat log files, but both adb.exe and monitor.bat do nothing when I open them, they both just flash up for a split second, then disappear. I've truly been searching quite exhaustively for a solution for some time now, and have seen no sign of an answer. I've been developing on a Motorola Moto E, and the game plays fine, next to the fact that it freezes up after being sent to the background... But otherwise, it works fine. Anywho, I have a few screenshots. Perhaps I've messed something up in one of them. Otherwise, if anyone has any clue as to why this might happen. I'd be forever in your debt. This has been a huge stresser, and I'm afraid I'll just have to publish the game without the Achievements and Leaderboards. So any help is appreciated. Please and thank you.

Login Blueprint:

alt text

Android Settings:

alt text

Google APIs:

alt text

Product Version: UE 4.10
Tags:
login blueprint.png (307.9 kB)
apis.png (46.3 kB)
more ▼

asked Feb 22 '16 at 02:02 PM in Blueprint Scripting

avatar image

Valmont Deimon
55 5 9 14

avatar image Valmont Deimon Feb 29 '16 at 08:11 PM

So, I have an update on this, and I'm hoping someone might be able to make some sense of it. I've been going through all the build logs after updating to Unreal 4.11 Preview 6. And near the top of the log, I found this:

MainFrameActions: Packaging (Android (ETC1)): UE4Editor-Cmd: LogModuleManager:Warning: ModuleManager: Unable to load module 'OnlineSubsystemGooglePlay' because the file 'C:/Program Files/Epic Games/4.11/Engine/Binaries/Win64/' was not found.

And then, much further down, right before COOK COMMAND COMPLETED this:

MainFrameActions: Packaging (Android (ETC1)): UE4Editor-Cmd: [2016.02.29-19.42.50:585][ 0]LogOnline:Display: NULL: FOnlineSubsystemNull::Shutdown()

MainFrameActions: Packaging (Android (ETC1)): UE4Editor-Cmd: [2016.02.29-19.42.50:585][ 0]LogOnline:Display: Unloading online subsystem: NULL

These, seem important to my problem. But it's odd, because I checked, and I definitely have a Win64 folder at the specified designation. Full of tons of important looking files. So I'm not sure what to make of it, or whether or not this could be the root of the problem, or perhaps a product of the real underlying issue. Anywho, if anyone can make heads or tails of this additional information. It would honestly mean a lot. My deadline for finishing this game is half a month away, and this is one of the last lingering issues I'm having. So please, if you might have any input at all, I'd truly appreciate it. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I too attempted to perfectly replicate match 3 and was having the same issues, I found It needed to be a for distribution release - my store/listing needed to be setup (i had it working then it stopped working)

but the last little tweak for me was my build.cs file, mine wasnt EXACTLY the same as match 3, upon rejigging it, I was then able to sign in again successfully

more ▼

answered Feb 01 '17 at 01:52 PM

avatar image

BPANDREW
995 22 27 125

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question