x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[4.10.2] Project works fine in Editor, Fails to Build

Really strange problem here, never had trouble Packaging my Project, Frontend, In-Editor, whatever it worked. Now, since about 1 or 2 weeks ago it wont build anymore. I didnt really changed anything inside the Project during that time, it just decided to stop building. The most suspicious Error/Warning (and the only one, really) is this:

UE4Editor-Cmd: [2016.02.22-17.36.56:498][ 0]LogLinker:Warning: Can't find file '/Game/Architecture/SM_Floor_400x400' UE4Editor-Cmd: [2016.02.22-17.36.56:499][ 0]LogUObjectGlobals:Warning: Failed to load '/Game/Architecture/SM_Floor_400x400': Can't find file '/Game/Architecture/SM_Floor_400x400' UE4Editor-Cmd: [2016.02.22-17.36.56:499][ 0]LogLinker:Warning: Can't find file '/Game/Architecture/SM_Floor_400x400' UE4Editor-Cmd: [2016.02.22-17.36.56:504][ 0]LogUObjectGlobals:Warning: Failed to load '/Game/Architecture/SM_Floor_400x400': Can't find file '/Game/Architecture/SM_Floor_400x400' UE4Editor-Cmd: [2016.02.22-17.36.56:506][ 0]LogUObjectGlobals:Warning: Failed to find object 'Object /Game/Architecture/SM_Floor_400x400.SM_Floor_400x400'

The strangest thing: I never used that Asset. It actually exists right were it should: StarterContent/Architecture/SM_Floor_400x400

i really have no idea what to do here, please help me!

Product Version: UE 4.10
Tags:
more ▼

asked Feb 23 '16 at 07:01 PM in Packaging & Deployment

avatar image

MrCkurab
1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I had this problem when I built a package for Android. It also kept getting stuck during the cooking and I had to cancel the build.

For me, it was because I am loading levels other than just the level the game starts with. The initial level loads a second one. It seems that in Android, if you do this you have to add something to the DefaultEditor.ini file for your project.

For example, if I have a level called "FooLevel" then I would put this into the ini

 [AlwaysCookMaps] 
 +Map=/Game/FooLevel

Once I did that then the packaging worked. I found some threads that confirm this to be an issue, but with different symptoms. Note that the full path to the level has to be specified.

more ▼

answered Jun 13 '16 at 10:56 AM

avatar image

Jin_VE
4.4k 32 77 42

avatar image zzzlor Feb 23 '16 at 07:28 PM

Find the folder with the project. And find that .uasset or file in Contetn/StarterContent/Architecture/. Then delete it. Good luck!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question