x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

SteamVR Controller Key Events Not Triggered

Hi there, I'm now working on a project with integration of SteamVR, but all of a sudden those key pressed events don't fire anymore.

Here's some clarification:

  1. It actually happened after I updated some codes of AI character and built my project, but I thought it hadn't anything to do with the SteamVR part.

  2. I tried some other projects (all using UE4.10) and found the key pressed events for SteamVR wouldn't fire either. Those projects didn't have code update for weeks and could trigger key events correctly last time I ran them.

  3. I also tried some Unity projects and the menu function (in which I may check with key events too) and they worked fine. Therefore it's not hardware issue.

  4. The keys I mainly used were MotionController L/R Grip 1 & MotionController L/R Trigger, which were mapped to grip & trigger keys of the SteamVR Controller. I didn't update my engine version or SteamVR api so I supposed those key mappings didn't change.

  5. If I change my key bindings (to keyboard keys or mouse buttons) in input setting panel, those action functions will get triggered as usual. Then it's not a issue of my coding.

  6. I've tried restarting my Unreal Editor, rebuilding my codes as a whole, or restarting all my SteamVR hardwares, but with no luck. I cannot restart my PC these days due to some reason so I didn't try this yet (and I'm not sure if that may help).

Any suggestions? Thanks in advance.

Product Version: UE 4.10
Tags:
more ▼

asked Feb 23 '16 at 04:53 AM in Bug Reports

avatar image

PhoenixThrough
101 18 23 30

avatar image Rudy Q ♦♦ STAFF Feb 23 '16 at 06:14 PM

Hello PhoenixThrough,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. When you say that you have tried this in other projects, does this mean that you can reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps on how to reproduce this issue on our end?

  3. Could you provide any code and/or screen shots of any blueprints that may be involved?

  4. If you have a clean project that reproduces this issue, would it be possible for you to provide it?

  5. If you provide a project, could you provide steps to reproduce the issue in the provided project?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I finally give my PC a restart and all things go on well now... Sorry I'm not able to reproduce this bug... Thanks a lot for your following my question and maybe I'll send a sample project next time I meet with this kind of issue

more ▼

answered Feb 24 '16 at 07:17 AM

avatar image

PhoenixThrough
101 18 23 30

avatar image Rudy Q ♦♦ STAFF Feb 24 '16 at 04:20 PM

I am happy to hear that you have things working on your end. I will be marking your last comment as the answer to this post for now. If this issue returns please feel free to reopen this thread with a reply that includes any additional information that you may have.

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question