x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

CrashOnAssert (3)

Hi,

I dont understand the error. This is the second time this error occur. The first time it was after creating a class deriving from Actor. While i get not over this error i've recreate the project from scratch (the same way/code as before) and the error was gone. Now i've created a new class deriving from CameraComponent. I've tried to regenerate visual studio project files, removed the class and recreated it, clean recompile but nothing of this worked.

I assume it has something to do with the generated header, in visual studio it is underlined red and the mouseover-popup says "source cannot be opened". But i have no idea how to fix it, please help.

 #pragma once
 
 #include "Camera/CameraComponent.h"
 #include "RPGCameraComponent.generated.h"
 
 
 
 UCLASS ( meta = (BlueprintSpawnableComponent) )
 class RPG_API URPGCameraComponent : public UCameraComponent
 {
     GENERATED_BODY ()
 
 public:
 
     UPROPERTY ( EditAnywhere, BlueprintReadWrite, Category = "CameraProperties" )
         float CameraPitch;
 
     UPROPERTY ( EditAnywhere, BlueprintReadWrite, Category = "CameraProperties" )
         float CameraDistance;
 
     virtual void GetCameraView ( float DeltaTime, FMinimalViewInfo& DesiredView ) override;
 
 };


Compiler output:

 1>------ Erstellen gestartet: Projekt: UE4, Konfiguration: BuiltWithUnrealBuildTool Win32 ------
 2>------ Erstellen gestartet: Projekt: RPG, Konfiguration: Development_Editor x64 ------
 2>  Creating makefile for RPGEditor (no existing makefile)
 2>  Performing full C++ include scan (no include cache file)
 2>  Parsing headers for RPGEditor
 2>    Running UnrealHeaderTool "C:\Users\Steffen\Documents\Unreal Projects\RPG\RPG.uproject" "C:\Users\Steffen\Documents\Unreal Projects\RPG\Intermediate\Build\Win64\RPGEditor\Development\UnrealHeaderTool.manifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -rocket -installed
 2>  C:/Users/Steffen/Documents/Unreal Projects/RPG/Source/RPG/RPGCameraComponent.h(11) : LogWindows:Error: Windows GetLastError: Der Vorgang wurde erfolgreich beendet. (0)
 2>  C:/Users/Steffen/Documents/Unreal Projects/RPG/Source/RPG/RPGCameraComponent.h(11) : LogWindows:Error: === Critical error: ===
 2>  Assertion failed: FoundClass [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Programs\UnrealHeaderTool\Private\HeaderParser.cpp] [Line: 4410]
 2>Error : Failed to generate code for RPGEditor - error code: CrashOrAssert (3)
 2>  UnrealHeaderTool failed for target 'RPGEditor' (platform: Win64, module info: C:\Users\Steffen\Documents\Unreal Projects\RPG\Intermediate\Build\Win64\RPGEditor\Development\UnrealHeaderTool.manifest).
 2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(37,5): error MSB3073: Der Befehl ""C:\Program Files (x86)\Epic Games\4.10\Engine\Build\BatchFiles\Build.bat" RPGEditor Win64 Development "C:\Users\Steffen\Documents\Unreal Projects\RPG\RPG.uproject" -rocket -waitmutex" wurde mit dem Code -1 beendet.
 ========== Erstellen: 1 erfolgreich, 1 fehlerhaft, 0 aktuell, 0 übersprungen ==========
 


Thanks

Product Version: UE 4.10
Tags:
more ▼

asked Feb 23 '16 at 06:15 PM in C++ Programming

avatar image

Aedificator
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

[SOLVED] Hi, after i've changed "UCLASS ( meta = (BlueprintSpawnableComponent) )" to "UCLASS(meta = (BlueprintSpawnableComponent))" [remove spaces] it compiles.

more ▼

answered Feb 25 '16 at 09:10 PM

avatar image

Aedificator
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question