x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Imported walls letting light in

I don't know if I'm doing something wrong, but my imported walls from blender keep some lighting inside (I think). If I build closed room with BSP, it gets completely dark, like I want. When I use imported meshes it get a wierd glow in the corners.

alt text alt text

Would appreciate some help with it.

Product Version: UE 4.10
Tags:
light.png (1.0 MB)
light2.png (996.7 kB)
more ▼

asked Feb 25 '16 at 06:40 AM in Rendering

avatar image

Rbacch
21 6 8 9

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi Rbacch,

When you import your mesh, depending on the UV layout for the lightmap you'll likely need to increase your Lightmap Resolution for the mesh. By default it will use a value of 64, so you may need to adjust the value to something higher like 128 or 256 to get better results, then rebuild lighting and see if that helps.

If you're still having issues, please post a screen shot of your Lightmap UV (UV Channel 1). You can do this by going to the Static Mesh Editor and hitting the UV button in the toolbar. Then in the drop down next to it, select UV Channel 1.

Thank you!

Tim

more ▼

answered Feb 25 '16 at 12:47 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 885 96 872

avatar image Rbacch Feb 26 '16 at 05:06 PM

Thanks for the reply, Tim, and sorry for the delay. I changed the lightmap resolution as you said, but the problem persists. I think the problem are the meshes overlapping each other, since I'm new to 3D modeling and I don't know about scaling or about anything. lol But since you asked, there's the UV Channel 0 (made by me on blender) and Channel 1 (auto generated by UE). About the lightmap, is there a problem, for example, my floor having a resolution of 128 and walls having 256?

Thanks again for the reply.

alt text alt text

untitled.png (418.6 kB)
untitled2.png (412.8 kB)
(comments are locked)
10|2000 characters needed characters left
  1. Make sure there's no gap where walls should come together.

  2. Check if it also happens if you switch to dynamic lighting and disable lightmaps altogether

  3. When you rebuild your lighting do you get any errors/warning?

more ▼

answered Feb 26 '16 at 07:55 PM

avatar image

phoboz
998 37 13 60

avatar image Rbacch Feb 26 '16 at 08:45 PM

Now i got it. For some reason there was a hidden gap that I couldn't find earlier. Thanks.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question