x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged executable error on run (win64)

When we package our projects everything seems to run fine with no warnings. However the executable doesn't have the proper icon, and when run it returns "This program is used for packaged games and is not meant to be run directly"

alt text

This is how the file looks:

alt text

We managed to fix this problem temporarily by creating a new project and migrating the content. After one successful build the issue returns, and re-migrating is required again. Obviously this is a time consuming fix.

Thank you for any suggestions.

Extra Info:

  • Running version 4.10.1.

  • Packaging in win64bit.

  • Tried 32bit but same problem.

  • Tried packaging to different drive.

  • Also tried changing between "shipping" and "development" configuration.

Product Version: UE 4.10
Tags:
packageerror.jpg (17.1 kB)
packageerror02.jpg (23.5 kB)
more ▼

asked Feb 25 '16 at 09:47 AM in Packaging & Deployment

avatar image

AlexJG
13 2 5 7

avatar image AlexJG Feb 25 '16 at 10:23 AM

We found that copying the project from the Z:Drive to the C:Drive and packaging from there works.

To confirm, it'll run a single time successfully from the Z:Drive, then subsequent packages have the error until the project is migrated.

Copying to the C:Drive allows the project to consistently package correctly, but we want to keep the project on the Z:Drive if possible.

It may be an issue with our drive setup rather than the engine.

avatar image Matthew J ♦♦ STAFF Feb 25 '16 at 10:31 PM

Hello AlexJG,

What is the resulting file path after you package to the Z: drive? Is it directly to the Z: drive or in a certain directory? Are there only two drives in your computer? If not, do any of the other drives that are not the C: or Z: act in this way? Also, is the Z: drive an external hard drive?

avatar image AlexJG Feb 26 '16 at 12:14 PM

Hi Matthew thanks for replying,

We're packaging from the Z:Drive to the C:Drive. The editor doesn't give us an option for packaging to the Z:Drive.

The Z:Drive is a shared network drive, though I'm not 100% on how it works/is set up.

avatar image Matthew J ♦♦ STAFF Feb 26 '16 at 02:52 PM

Hm, it seems like the .exe might be having problems overwriting the old version. From the picture you provided, it seems like it hadn't been updated in over a month, while the other folders had. You also claim that it works the first time but then doesn't work on subsequent packaging attempts. To test this, could you try deleting the .exe from the directory and then packaging to that same directory again?

avatar image AlexJG Feb 29 '16 at 09:29 AM

Good spot Matthew, that file was definitely packaged to a brand new directory on the day I posted the question; it shouldn't be showing Jan on the Date Modified tab. I don't know what that means but it seems likely to be relevant.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

It seems like this may be an issue with the drive setup as you previously mentioned, especially if the Z: drive is a virtual drive. Have you been able to try packaging to the same directory after deleting the executable from the previous version to see if it works correctly then?

more ▼

answered Mar 02 '16 at 09:01 PM

avatar image

Matthew J ♦♦ STAFF
31.8k 526 92 417

avatar image AlexJG Mar 03 '16 at 09:51 AM

Thanks Matthew, yes we just tested it out and it's still says the new executable was made in January. I think we're going to just use the "copy to C:Drive" fix for now. Thanks very much for all your help

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question