x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cinema 4D R17 FBX Smoothing Groups error 4.10

First of all, I'm aware that plenty of people posted about this before and I think I've read almost every topic about it. However, most topics are about UE 4.5 or 4.6 and they use Cinema 4D R15 or R16. In the mean time both software has changed quite a bit and none of the previous provided solutions seem to work (disable edge break, use specific FBX version etc.)

So the issue I'm having is no matter what FBX version I try for export, I always get a smoothing group error when importing the model inside Unreal Engine. I'm also bound to the FBX 6.1 format otherwise another issue arises where none of the textures are imported if I use any of the later FBX formats. I can't export the model to Maya or 3DS Max first because I do not own the software and I like to refrain from a devious pipeline where I need to follow a chain of programs before I can finally export something.

Does anyone know if there's a proper way to get this fixed or to work around it?

Even though it seems to be a problem related to C4D, I've never witnessed an update from Maxon's end that fixes issues like this so hopefully can Epic take a look at this if it's a bug. Switching software is a no go. Goes for both the 3D tool and the engine.

Product Version: UE 4.10
Tags:
more ▼

asked Feb 26 '16 at 10:55 AM in Bug Reports

avatar image

Mr Robville
32 18 23 22

avatar image Lovecraft_K ♦♦ STAFF Feb 26 '16 at 03:46 PM

Hello Mr Robville -

We don't extensively use Cinema 4D internally, but we can look into the issue for you. Can you post a sample Cinema 4D file that causes this issue for us to poke around with?

Thank You

Eric Ketchum

avatar image Mr Robville Feb 27 '16 at 02:02 PM

Hello Eric,

Thanks a lot for your time. I've tried to make a quick sample file that has this issue, but I found something weird. I first made a simple blob with a texture and exported it as FBX 6.1. When I imported it, the error message still showed but the blob was completely smooth. No issues whatshowever. I then took a piece from one of my scene models and exported it separately. Again, error showed up but the smoothing was exactly as it should. Then I tried exporting the whole scene model again (thinking the planets must have alligned or something causing this sudden solution) but this time all smoothing was gone. I want to send you this scene file so you can try it out yourself, but I don't want it to be available for public. Can I send you it to you in private?

You'll notice that if you export the entire scene that the smoothing is broken, but if you take a couple individual objects and export them separately from the scene, the smoothing works fine. Makes me think that it could be related to a maximum number of polygons or something.

avatar image Lovecraft_K ♦♦ STAFF Feb 29 '16 at 02:50 PM

Hello -

Yes, You can link it to me via the Private Message system on the forums.

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi Mr Robville -

Thank you for your assistance so far. After some work with your assets I boiled the issue down to the FBX exporting from Cinema4D trying to calculate the Phone Smoothing for a large scene seems to lose information in the exported file. The error message from the editor will always be present because the engine does not know how to read Phong Smoothing, but the FBX seems to be able to store a limited amount of data which stores the calculated smoothing.

Long story, short. I would recommend exporting your scene in small chunks, individual assets with the common pivot (so leave them in position) and place all the assets which you have been able to bring into the engine with smoothing into a Blueprint to recreate the whole room.

Ultimately the FBX export options for Cinema 4D would need the option to store the calculated normals generated by the Phong Smoothing, then they should import without error and as a whole into UE4.

Thank You Again for your assistance -

Eric Ketchum

more ▼

answered Mar 02 '16 at 05:43 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 701 255 733

avatar image Mr Robville Mar 08 '16 at 07:38 AM

Hi Eric,

Thank you very much for having looked into this! I shall provide this information to Maxon. Hopefully they are willing to fix it. For now I'll split the scene in chunks.

avatar image Jihed.Jaouabi Apr 22 '16 at 11:37 AM

Hi Rob, I have the same issue but I have Cinema4D R16, I can't import smoothing groups (phongs for C4D) in UE4.11. I just want to export a 3D character (and not a complicated scene so I can split into chunks). Any Thoughts?

avatar image Mr Robville Apr 22 '16 at 11:53 AM

Hi Jihed, I believe I've read somewhere that with R16 you could export it to FBX 6.1 or 7.1. In R17 I'm forced to use 6.1, otherwise all textures are gone. Also make sure to check "Textures and Materials" & "Embed Textures" and that geometry is triangulated as well.

avatar image Jihed.Jaouabi Apr 28 '16 at 10:02 AM

I tried both with FBX 6.1 and 7.1 no success, but I'll keep tweaking stuff, if I find a solution I will let people know about it.

avatar image Eskel Jan 17 '17 at 05:36 PM

I can't get this to work even on very small meshes (cilinders, spheres), in latest UE and C4D. No FBX version works.

(comments are locked)
10|2000 characters needed characters left

This plugin seems to do the trick .... http://www.cactus3d.com/CDFBX.html Its $30 but tested and working perfectly using C4D R16 + UE4.13.

It uses FBX 2014.

https://postimg.org/image/hoef6etzh/

more ▼

answered Dec 01 '16 at 02:24 AM

avatar image

ChaNinja
1 1 1

avatar image Eskel Jan 17 '17 at 05:35 PM

Sadly Cactus Dan passed away, and the site is not running anymore. :(

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question