x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error when saving a map while uploading to cloud service, when reopening project, map is deleted

I use a cloud backup service for backing up data, which works fine, but when I tried to save the map while project files were getting uploaded, I got an error, and when I reopened the project my map was gone (everything black, all placed things were gone). This doesn't happen when I pause the uploading process before working on my project (like I usually do, uploading everything when done instead).

I don't know how many people actually do this but it might be worth taking a look into. Here's a video (some loud shooting sounds at the end): https://www.youtube.com/watch?v=IJ7w4PKaRhw&feature=youtu.be

I'll attach some logs too. Log 1 Log 2

Product Version: UE 4.11 Preview
Tags:
bugtest.log (40.2 kB)
bugtest_2.log (39.7 kB)
more ▼

asked Feb 27 '16 at 11:46 PM in Bug Reports

avatar image

cyaoeu
138 9 12 23

avatar image Sean L ♦♦ STAFF Mar 01 '16 at 03:53 PM

Hello,

I have attempted to reproduce your issue, but have experienced a few different results. The first time I attempted it, I got no error message in the editor, but when I downloaded the project again and opened it, the map was gone as you stated.

The second and third times I tested, I was not able to complete my upload to cloud storage, as once I saved the map the download paused and did not finish. Have you seen this behavior as well?

avatar image cyaoeu Mar 01 '16 at 06:09 PM

I didn't actually test downloading the project again, but it should be the same as the local copy is what's getting uploaded. I tested it a bit more and saw that as long as you don't save the map when you're not actually uploading the map you're fine, but if you save as the map is getting uploaded (the map file with lots of numbers appended to it) you get an error and the next time you run the project it's gone.

I didn't test to see what would happen if you saved again after getting the error though, if it fixes things or doesn't change anything.

I was able to upload everything to cloud storage. There were some hickups on certain files but I think that was just my connection being slow. The only real times you would run into this bug (with cloud storage) is if you saved the files right after starting a new project (while the map was being uploaded), if you accidently saved the file twice in a row, or manually save after an autosave (if that actually saves the map, I'm not sure).

The easiest way to reproduce this is creating a new project, wait for everything to upload, then save a couple of times until you get an error.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

It is not recommended that you upload your project to cloud storage while it is open. This can definitely cause corruption in certain files if you are attempting to access them while they are being uploaded.

If you are using cloud storage as a form of source control, have you considered using perforce or another form of source control? Take a look at our documentation for source control and see if this is something that would work for you:

https://docs.unrealengine.com/latest/INT/Engine/Basics/SourceControl/InEditor/index.html

https://docs.unrealengine.com/latest/INT/Engine/Basics/SourceControl/Perforce/

https://docs.unrealengine.com/latest/INT/Engine/Basics/SourceControl/SVN/index.html

more ▼

answered Mar 01 '16 at 07:18 PM

avatar image

Sean L ♦♦ STAFF
44k 485 149 438

avatar image cyaoeu Mar 01 '16 at 08:08 PM

Yes, since I found out about this I've been looking into perforce. I will probably move the UE4 project folder out of the cloud folder, then use a local perforce server with cloud backups of the perforce data folder (I don't really need backups of the versioning). If this even works.

This way saving in UE4 should work normally and I can still backup the project by checking it out to perforce. Theoretically of course... I haven't tested this setup yet.

avatar image Sean L ♦♦ STAFF Mar 01 '16 at 08:44 PM

That sounds like a better plan, and it allows you much more control over how you store your project and keeps you from losing tons of work.

With the documentation provided as well as the numerous Answerhub posts you can find regarding how to get source control working, you should be well on your way to setting it up.

Have a great day

avatar image cyaoeu Mar 02 '16 at 02:04 AM

I couldn't actually get this to work, the perforce workspace had to be the same folder as the UE4 project, and from there it seemed impossible to check out the project to multiple locations. I am stuck with manual backups for now which isn't ideal, but better than data loss I guess...

avatar image Sean L ♦♦ STAFF Mar 02 '16 at 01:35 PM

As far as your issue itself goes, have you tried to use another cloud storage service, such as Google Drive and see if you get the same error when saving your map(s)?

avatar image cyaoeu Mar 02 '16 at 03:25 PM

Yes, Google Drive does the same thing, when you save while the map is getting uploaded you get an error, then when you reload the project the map is gone.

Looking through the logs it looks like UE4 saves the map with a hash to a folder, then moves this new file to the original map location and overwrites it, but because of the original file getting accessed it can't get overwritten so strange things happen. I don't see why this would lead to everything disappearing from the map though. I could understand if the map stayed the same (without the saved changes), but if it couldn't be saved, why is something changing? (Stuff getting deleted from the map)

This is what made me file this as a bug, but it could just be a design thing which had unintended consequences in this particular case.

avatar image Sean L ♦♦ STAFF Mar 03 '16 at 04:31 PM

For this particular issue, I recommend not uploading the project while it is open, or saving files while they are being uploaded, as this is definitely something that can cause corruption.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question