x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Texture loses alpha on export

I picked up some textures from an asset pack. The textures are too large, so I wanted to downscale them in Photoshop. When I export them though, the alpha disappears. The result looks like the in-engine thumbnail, where the edges bleed all the way out to fill the empty space. I also can't find any way to just grab the source files from the asset directly without first adding them to a project, so I'm stuck. Is there any way to export the textures properly, with the alpha channel intact?

Product Version: UE 4.10
Tags:
more ▼

asked Feb 27 '16 at 11:49 PM in Rendering

avatar image

Grimwolf
157 14 15 25

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

When you open it in Photoshop is the alpha channel info there? And are you sure you are exporting in a format that supports alphas like .tga?

more ▼

answered Feb 28 '16 at 03:40 AM

avatar image

EyeDee10Tee
2.1k 59 14 126

avatar image Grimwolf Feb 28 '16 at 04:33 AM

Ah, you're right. The alpha channel is intact, Photoshop is just refusing to display it for some reason. It's TGA format, so it should be able to display it fine. Any idea what could be causing that? The problem is unique to assets exported from UE4. The alpha displays fine with other TGA files I have.

avatar image EyeDee10Tee Feb 28 '16 at 05:31 AM

What is the alpha doing? Because you can use alphas to do a variety of things. I generally use it as a mask but it can be used to drive specularity, opacity and a few other things. Would you mind sharing one of the files so I can see what's going on with it?

avatar image Grimwolf Feb 28 '16 at 02:35 PM

I can't share it because it's an asset I purchased. I'm using it to drive opacity. The alpha channel is starting out disabled by default in Photoshop, and if I enable it myself, it behaves as a 2nd Red channel. Which is very strange. The normal red channel is also functional. Enabling it basically just turns the background red.

avatar image Luos Feb 28 '16 at 05:57 PM

thats normal alpha behaviour in photoshop. If you enable it, it shows as a red overlay.

Just be sure you save the tga as 32 bit, and make sure you didnt turn on "save without alpha" in the texture menu in ue4.

avatar image Grimwolf Feb 29 '16 at 03:07 PM

How would I get Photoshop to display the alpha properly? It makes editing the textures very difficult.

avatar image EyeDee10Tee Feb 29 '16 at 09:39 PM

Goto the channels tab on the right. Disable R,G,B channels to see the alpha

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question