x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Multimaterial translusent object shadows

Hello folks!

I'm trying to make glass door - or actually make correct translucency and shadows for it. I expect that glass will pass light and wood will cast shadows, but it doesn't seem to happened. I was trying to use the door for the Starter Content as well as my own mesh, but without any success. Actually starter content door doesn't pass light at all. All I have there is weird reflections on the door frame. :(

My lights are movable spots(except 2nd from the left side - there's point light) with "Cast translucent shadows" checked. Meshes also have "Volumetric translucent shadows" enabled.

alt text

Any tips\solutions\coplanar articles/hub topics links are highly appreciated!

Cheers, Ivan.

Product Version: UE 4.10
Tags:
more ▼

asked Feb 29 '16 at 05:31 PM in Rendering

avatar image

Inviter42
15 1 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Ivan,

4.10 had an issue with Translucent Materials blocking any light like this unless it was selected in the viewport. This has been resolved in 4.11. You can test this for yourself in 4.11 Preview 6, which is available via the Epic Games Launcher.

Thank you!

Tim

more ▼

answered Feb 29 '16 at 08:20 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image Inviter42 Feb 29 '16 at 08:32 PM

Hi Tim,

Yeah, this is good, but I have the same problem in the game(in playmode) as well.. So that screenshot above is from the playmode actually.

avatar image Tim Hobson ♦♦ STAFF Feb 29 '16 at 08:39 PM

Right, this was an issue with 4.10 in general from what I remember and using multi-material objects. If you need to stick with 4.10, thena workaround would be to break the glass/translucent material out as its own object. That would be the only way to get it working without source code and implementing a fix.

avatar image Inviter42 Feb 29 '16 at 09:06 PM

Oh, okay then. Glad to hear that this was fixed. Thanks for your help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question