x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

FPS blueprint template causes AMD drivers to crash when firing many projectiles, occasionally crashes entire system

Steps to repeatedly recreate:

  1. Open UE4, create a new project using the blueprint FPS template

  2. Enter play mode in the editor

  3. Fire many projectiles into the air/into the world. Usually takes 5 to 10 seconds of this to cause the crash

Results of the bug:

  • AMD drivers will crash. My screen simply turns black for a few seconds while they attempt to recover. A basic driver crash warning is entered into windows Event Viewer stating the driver crashed and tried to recover

  • Following the drivers, the engine will crash

  • Usually the drivers recover after the engine crashes. Occasionally they do not and the system either crashes or needs to be reset.

  • If the drivers recover, attempting to un-minimize Epic Games Launcher causes it to crash.

What I have tried:

  1. Ensured my graphics drivers were up to date for my card (R9 380x 4GB, used AMD's automatic tool). They were, no effect.

  2. Updated my graphics drivers to AMDs beta "Crimson 16.1 Hotfix". No noticeable effect.

  3. Installed AMDs "Software Beta for Vulkan". No noticeable effect.

  4. Made this post.

I appreciate any help or guidance. I'm ready to provide any information that is necessary to resolve the issue.

Product Version: UE 4.10
Tags:
more ▼

asked Mar 01 '16 at 10:09 PM in Bug Reports

avatar image

ARC157
13 1 4

avatar image Shadowriver Mar 02 '16 at 01:23 AM

You know this can be also driver bug

avatar image ARC157 Mar 02 '16 at 05:23 PM

Of course! That's why I tried updating my drivers, unfortunately to no effect. So it very well may still be solely a driver bug that hasn't been addressed. I'm hoping that if someone else has had a similar issue then some parallels might be able to be drawn.

I will note some extra info here: This only happens for me with the fps template. I'm thinking it might have something to do with the projectile blueprint and its underlying components - perhaps the projectile component. We don't use those sort of projectiles anywhere else (using ray traces instead) and so I can fire custom weapons all day with no issue.

I'll try to set up a custom projectile and see if I can narrow down which component might be the root that triggers the crash (or triggers the driver bug which causes the crash)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi ARC,

Thank you for the report.

Yes, this is something that was noticed internally as well and it's logged as JIRA UE-24826. It seems to be specifically related to AMD cards with the Crimson update that are on Windows 10. Our developers are working with AMD to investigate the issue further. We will post here with additional questions if needed.

Cheers,

TJ

more ▼

answered Mar 02 '16 at 06:35 PM

avatar image

TJ V ♦♦ STAFF
41k 1009 183 494

avatar image ARC157 Mar 02 '16 at 07:04 PM

Thanks for the quick reply and info. Happy to hear it's on the teams as well as AMD's radar.

Is there a public utility available to track the status of bugs?

avatar image TJ V ♦♦ STAFF Mar 02 '16 at 07:06 PM

Not yet, however that is also something that we are looking into.

avatar image ARC157 Mar 02 '16 at 07:12 PM

Thanks. Happy to hear that as well.

avatar image TJ V ♦♦ STAFF Mar 29 '16 at 12:34 PM

Hey ARC157,

We have tested this internally and it looks like updating to version 16.3.1 (Driver Packaging Version 16.15.2111-160314a-300497E) fixes the issue for us. Could you give that a try and let us know if it's fixed for you as well?

Cheers,

TJ

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question