x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor crashes on launch with error in Casts.cpp

I was experimenting with the c++ code of a project when suddenly the editor crashed. I reverted all of the changes I had made and rebuilt the solution but it still crashes whenever I try to open it in the editor. I get the following error message in the crash report:

 Unknown exception - code 00000001 (first/second chance not available)
 
 "Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\CoreUObject\Private\Templates\Casts.cpp] [Line: 11] 
 Cast 
 
 UE4Editor_Core!FDebug::AssertFailed() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\misc\outputdevice.cpp:374]
 UE4Editor_CoreUObject!CastLogError() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\templates\casts.cpp:12]
 UE4Editor_Engine!CastChecked<ULevel,UObject>() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\public\templates\casts.h:195]
 UE4Editor_Engine!TActorIteratorBase<FActorIterator>::operator++() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\public\engineutils.h:253]
 UE4Editor_Engine!UWorld::UpdateCullDistanceVolumes() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\world.cpp:1383]
 UE4Editor_Engine!UWorld::InitializeNewWorld() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\world.cpp:1095]
 UE4Editor_Engine!UWorld::CreateWorld() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\world.cpp:1170]
 UE4Editor_Engine!UEngine::Init() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\unrealengine.cpp:801]
 UE4Editor_UnrealEd!UEditorEngine::InitEditor() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\unrealed\private\editorengine.cpp:430]
 UE4Editor_UnrealEd!UEditorEngine::Init() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\unrealed\private\editorengine.cpp:585]
 UE4Editor_UnrealEd!UUnrealEdEngine::Init() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\unrealed\private\unrealedengine.cpp:50]
 UE4Editor!FEngineLoop::Init() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launchengineloop.cpp:2094]
 UE4Editor_UnrealEd!EditorInit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\unrealed\private\unrealed.cpp:63]
 UE4Editor!GuardedMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launch.cpp:133]
 UE4Editor!GuardedMainWrapper() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
 UE4Editor!WinMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:200]
 UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264]
 kernel32
 ntdll

I found the file it was complaining about (Casts.cpp) and saw that some errors are present. The main one seems to be "Cannot open source file "CoreUObjectPrivate.h""

alt text

Anyone have any ideas on how to fix this?

Product Version: UE 4.10
Tags:
casts error.png (22.8 kB)
more ▼

asked Mar 03 '16 at 12:12 PM in Bug Reports

avatar image

Decdot
26 1 3 8

avatar image Doug E ♦♦ STAFF Mar 03 '16 at 02:37 PM

Hey Decdot-

Can you post the exact compile error you're getting now? Based on where the callstack mentions the Casts.cpp file it appears that an attempt to make a cast call is failing somewhere. Can you post the class(es) that you were working in when this crash occurred?

avatar image Decdot Mar 03 '16 at 02:49 PM

I don't think it's a problem in the class I was editing (APaperCharacter class), as in an attempt to find the problem I completely commented out most of the logic in the MyPaperCharacter.cpp file I was working on and rebuilt the solution. If you would still like to take a look at the file I would be happy to post it, but it is around 300 lines long so would it be best to upload the file to a download site or simply copy/past it here?

avatar image Doug E ♦♦ STAFF Mar 03 '16 at 03:04 PM

It would work if you are able to attach the files (.h and .cpp) themselves here or you can upload them someone and provide the link here to download.

avatar image Decdot Mar 03 '16 at 04:29 PM

link text

Thanks for taking a look at this for me. I have attached the .h and .cpp of my main character class. This is the version that should work (but doesn't), as I reverted the changes after it started crashing.

codefiles.zip (4.0 kB)
avatar image Doug E ♦♦ STAFF Mar 04 '16 at 05:20 PM

Because the crash is happening when the project is being opened, it is likely that a file is trying to access another file or class before it has been fully setup which the editor can't handle. It's possible that another asset was edited that caused the editor to have this conflict. Before this crash started occurring, were you working in any blueprints where you added cast calls? Something else you can test is to remove the Content folder from the project directory and slowly reintroduce it and its subfolders to see if a specific asset is corrupted.

avatar image Decdot Mar 05 '16 at 11:30 AM

I don't remember using any casts in the code or in blueprints. I actually didn't use any blueprint scripting as I was trying to stick to C++. I removed the content folder like you suggested but the same crash happens with the same error.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I'm not sure if this counts as a 'fix', but I just made a new project and copy/pasted my classes and assets. It works now.

more ▼

answered Mar 05 '16 at 02:39 PM

avatar image

Decdot
26 1 3 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question