x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

FBX skeletal mesh imports as multiple objects

Hi, I'm trying to import an .fbx file as a skeleton mesh and I need it to be one asset. In 3ds Max it's several objects that I select and export as a single .fbx file. But UE4 keeps importing them as several separate skeletal meshes. I know there is an option "combine mesh" for static mesh import, but I import a character for animation and I need it to be a skeletal mesh. Is there any way to import it as a single asset? Thanks.

Product Version: UE 4.10
Tags:
more ▼

asked Mar 03 '16 at 07:15 PM in Using UE4

avatar image

StMalk
87 14 18 48

avatar image fxckenstein Jul 05 '17 at 06:05 AM

By default the unreal engine do import as a single object, even if you have multiple object selected when export. But I just had this weird problem today that all the skeleton mesh I import to unreal engine turned into multiple objects and multiple skeletons, I tried both 4.15 and 4.14 with no luck.

(comments are locked)
10|2000 characters needed characters left

5 answers: sort voted first

Because your bone groups are seperate unreal will always read it that way. It's the nature of animations and rigs. If you want it all as one skeletal you will have to combine them in 3ds max

more ▼

answered Mar 03 '16 at 08:22 PM

avatar image

EyeDee10Tee
2.1k 59 14 126

avatar image StMalk Mar 03 '16 at 08:41 PM

So I just combined it all in one mesh with multiple elements. Even though I still can't import anything as I'm using CAT rig and it gives me "can't import asset, multiple roots" error, I think it will be a single mesh now though.

(comments are locked)
10|2000 characters needed characters left

Maybe you can try importing the mesh into Blender and parent/childing the mesh making it read as a whole. I tried that multiple times and it has worked.

more ▼

answered Mar 05 '16 at 06:57 PM

avatar image

imoutof1deas
16 1 2 8

avatar image tonechild Jan 16 '18 at 11:08 PM

Thanks! This worked well for me too

avatar image UpliftingBruno Sep 12 '18 at 03:15 PM

That´s worked for me as well!

(comments are locked)
10|2000 characters needed characters left

Thats not true. You dont need to combine the parts in the 3d app to have em combined in UE. I am having this exact same problem but i know it should work because the first time i imported my skeletal mesh into UE, it automatically combined all the parts. I needed to delete the imported mesh because i made changes in blender, and when i go to make the same import process in UE, this time i cant get the whole mesh in one piece.

Any ideas?

more ▼

answered Feb 17 '18 at 03:09 AM

avatar image

amstradcpcuser
31 3 9 13

(comments are locked)
10|2000 characters needed characters left

Hai,

For this multiple import issues, there is a settings in Maya only. Kindly go to the Outliner Window and Select what are object need to make one object in outliner then press crlt + g it make the groups then export and import to UE4 then it import as single object.,

more ▼

answered Sep 20 '18 at 01:09 PM

avatar image

JohnCreater
1

(comments are locked)
10|2000 characters needed characters left

I've noticed that this also can happen if the Skin binding process was not properly finished. (Rigid + Smooth Bind)

more ▼

answered Apr 17 '19 at 07:33 AM

avatar image

RC_Malokai
21 1 3

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question