x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Compiler Checks Win64 Folder Instead Of Android Folder?

When I compile my Android project with GooglePlay active, the compiler checks the Engine/Binaries/Win64 for the OnlineSubsytemGooglePlay, instead of the Engine/Binaries/Android folder. Giving me this Error:

MainFrameActions: Packaging (Android (ETC1)): UE4Editor-Cmd: LogModuleManager:Warning: ModuleManager: Unable to load module 'OnlineSubsystemGooglePlay' because the file 'C:/Program Files/Epic Games/4.10/Engine/Binaries/Win64/' was not found.

The Win64 folder doesn't have any GooglePlay files associated with it, so I'm not sure why it goes to that folder. Does anyone know why it might check the wrong location, or know how I could manually make it check the right one?

Btw, this occurs for me in the 4.10 as well. I'm working with 4.11 Preview 6 now..

Edit: Not sure how I didn't notice this before, but this error actually pops up in the Output Log upon loading up the project. In nice bright yellow letters. Here's a screenshot.

alt text

Most of this stuff seems important, but I'm not sure how to change it. My default profile and default folder locations all point to the Win64, despite making an android game. Anyone know how to change this?

Product Version: UE 4.11 Preview
Tags:
output log.png (112.2 kB)
more ▼

asked Mar 05 '16 at 03:11 AM in Packaging & Deployment

avatar image

Valmont Deimon
55 5 9 14

avatar image Samantha Sutton ♦♦ STAFF Mar 11 '16 at 05:30 PM

Valmont,

Please make sure it's connected to your phone and run the following: C:\NVPACK\android-sdk-windows\tools and open up Monitor.bat

Once you have that up, open up the game on your device and then capture the logs. Make sure that you highlight every single line that you want to obtain for us within Monitor.bat before saving it otherwise it saves a blank notepad file.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Valmont,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered Mar 21 '16 at 02:18 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

It tries to load OnlineSubsystemGooglePlay module and engine running on windows will obviously look up for binary in Win64 (or Win32 if you run 32-bit), GooglePlay support is only implemented to work on Android so it won't build on Windows.

My guess is you set subsystem in config and engine will try to load it in Windows too (and fail). So if it build anyway, just ignore it :)

more ▼

answered Mar 06 '16 at 04:25 AM

avatar image

Shadowriver
36.7k 932 169 1111

avatar image Valmont Deimon Mar 06 '16 at 06:02 PM

Thank you for the response. :)

But should it still not find it, even if my game is for Android? My game needs Google Play to work for Achievements Highscores, Advertising, etc., but when it complies for Android ETC1, it still can't find OnlineSubsytemGooglePlay. And no matter what I do, When I play the game on my Android phone, it won't connect to GooglePlay. In fact, the ShowExternalLoginUI doesn't even show up, to ask the player to login. I mean sure, I'm using the editor on a 64 bit Windows, but I'm not compiling it for Windows.

Ugh... It's been like that for so long, I really thought I had narrowed down the problem to this error. Because it show's up on Editor start, and when compiling... I've tried modifying DefaultEngine.ini and Build.cs which is what I keep seeing other people do, but nothing seems to work...

avatar image Shadowriver Mar 07 '16 at 05:30 PM

Those errors are happening on Windows and it load attempt that happerns on Windows, if you want to see Android logs check logcat (http://developer.android.com/tools/debugging/ddms.html ), UE4 logs there on device.

Google Play require some extra stuff to work: https://forums.unrealengine.com/showthread.php?21803-Google-Play-Setup Did you follow that?

avatar image Valmont Deimon Mar 07 '16 at 10:39 PM

I'll try getting the logs, and perhaps going back through the setup process with the Google Play Developer Console. But I believe I've already got it set up properly. This is a slightly older question I asked about the External Login UI not appearing. It has a bunch of screenshots pertaining to my setup:

https://answers.unrealengine.com/questions/379327/android-external-login-ui-doesnt-appear.html

avatar image Shadowriver Mar 07 '16 at 11:45 PM

you signed your apk?

avatar image Valmont Deimon Mar 08 '16 at 12:34 AM

Yeah, all that's been done, I even have my game on the Google Play Store, it's just in Alpha so only I can download it. Its linked to my Game Services, and they are both published.

Also, I have the Android Device Manager Up, with my phone connected, but I'm not sure how to get it to obtain logs for my game. The log at the bottom just goes crazy with updates, not sure how to get the logs pertaining to my game.

avatar image Shadowriver Mar 12 '16 at 02:51 AM

Apply log filter for UE4 tag and process name

avatar image Samantha Sutton ♦♦ STAFF Mar 16 '16 at 07:34 PM

Valmont, have you tried the suggestions provided by ShadowRiver to obtain the proper logs?

Thanks!

avatar image Valmont Deimon Mar 22 '16 at 10:32 AM

Sorry, been away for a week. I have tried to get the logs. But 'UE4' doesn't seem to work as a tag filter. None of the output has an Application Name associated with it. And when I just try saving the entire log, the log file is blank.

But, I did use the built in filter for only printing out errors, then copy pasted that into Notepad++, with the following results:

link text

Not sure if that's useful or not. But it definitely mentions numerous issues with the WifiStateMachine. And tries opening an unimplemented OpenGL API. So perhaps that's the issue. Any suggestions? Please and thank you. :)

log.txt (3.6 kB)
avatar image Samantha Sutton ♦♦ STAFF Mar 30 '16 at 06:44 PM

When your phone is connected to your computer and you're running your game, do you have Monitor.bat open collecting the logs? If so, make sure you highlight from the top down to the bottom and save. If you do not save that way, it will not record any of the logs.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question