Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Reopening a level fails

I've got a problem with my levels setup: I have a level which contains a proper game level and a level which acts as a loading screen. When you open the loading screen level, it will automaticly load the game level.

Transitioning from the level to the loading screen works fine, but when the loading screen tries to open the level again, the game shuts down. In some cases, the editor even crashes and I get the error Assertion failed: WorldContext.World()->GetOutermost()->HasAnyPackageFlags(PKG_PlayInEditor).

I also started the loading screen, which opens the level, but when I try to get to the loading screen again, I get the same result.

I'm addressing the levels directly by their paths, which are correct, and using the openLevel-Node.

What am I doing wrong? Help me, please.

Here are the logs, one with an editor crash and one without

Product Version: UE 4.10
more ▼

asked Mar 05 '16 at 08:40 PM in Blueprint Scripting

avatar image

6 2 3 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

this was happening with 4.10.3. did you upgrade to 4.10.4 hotfix? i believe this issue may have been fixed in the 4.10.4 hotfix.

more ▼

answered Mar 07 '16 at 04:30 PM

avatar image

1.2k 49 31 87

avatar image Janonard Mar 08 '16 at 03:17 PM

I tried it, but it doesn't work. It is the same as before.

avatar image shared_pointer Jun 29 '16 at 01:26 PM

Hi, I'm having this issue with 4.12.3, did you find a solution? Thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question