x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging Fails on Mac

Hi, I created a starter project and tried to package for Mac but I get this error:

 MainFrameActions: Packaging (Mac): mono: [8/12] Link Strat-Mac-Shipping
 MainFrameActions: Packaging (Mac): mono: [9/12] sh -c 'rm -rf "/Volumes/Seagate_Expansion_Drive/Unreal/Strat/Binaries/Mac/Strat-Mac-Shipping.app/Contents/MacOS/Strat-Mac-Shipping.dSYM"; "/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/"dsymutil -f "/Volumes/Seagate_Expansion_Drive/Unreal/Strat/Binaries/Mac/Strat-Mac-Shipping.app/Contents/MacOS/Strat-Mac-Shipping" -o "/Volumes/Seagate_Expansion_Drive/Unreal/Strat/Binaries/Mac/Strat-Mac-Shipping.app/Contents/MacOS/Strat-Mac-Shipping.dSYM"; mv "/Volumes/Seagate_Expansion_Drive/Unreal/Strat/Binaries/Mac/Strat-Mac-Shipping.app/Contents/MacOS/Strat-Mac-Shipping.dSYM" "/Volumes/Seagate_Expansion_Drive/Unreal/Strat/Binaries/Mac/Strat-Mac-Shipping.dSYM"'
 MainFrameActions: Packaging (Mac): mono: Fixing dylib dependencies for Strat-Mac-Shipping.dSYM
 MainFrameActions: Packaging (Mac): mono: Finalizing app bundle: Strat-Mac-Shipping.dSYM.app
 MainFrameActions: Packaging (Mac): mono: Copying RadioEffectUnit.component to app bundle
 MainFrameActions: Packaging (Mac): mono: -------- End Detailed Actions Stats -----------------------------------------------------------
 MainFrameActions: Packaging (Mac): mono: Total build time: 42.42 seconds
 MainFrameActions: Packaging (Mac): mono: Compiling with MacOSX SDK 10.11
 MainFrameActions: Packaging (Mac): mono: Deploying now!
 MainFrameActions: Packaging (Mac): CommandUtils.Run: Run: Took 42.613459s to run mono, ExitCode=0
 MainFrameActions: Packaging (Mac): BuildCommand.Execute: ERROR: BUILD FAILED
 MainFrameActions: Packaging (Mac): Program.Main: ERROR: AutomationTool terminated with exception:
 MainFrameActions: Packaging (Mac): Program.Main: ERROR: Exception in AutomationUtils.Automation: BUILD FAILED /Volumes/Seagate_Expansion_Drive/Unreal/Strat/Binaries/Mac/Strat-Mac-Shipping.dsym was in manifest but was not produced.
 MainFrameActions: Packaging (Mac): Stacktrace:   at AutomationTool.UE4Build.AddBuildProductsFromManifest (System.String ManifestName) [0x00000] in <filename unknown>:0 
 MainFrameActions: Packaging (Mac):   at AutomationTool.UE4Build.BuildWithUBT (System.String ProjectName, System.String TargetName, UnrealTargetPlatform TargetPlatform, System.String Config, System.String UprojectPath, Boolean ForceMonolithic, Boolean ForceNonUnity, Boolean ForceDebugInfo, Boolean ForceFlushMac, Boolean DisableXGE, System.String InAddArgs, Boolean ForceUnity, System.Collections.Generic.Dictionary`2 EnvVars) [0x00000] in <filename unknown>:0 
 MainFrameActions: Packaging (Mac):   at AutomationTool.UE4Build.Build (AutomationTool.BuildAgenda Agenda, Nullable`1 InDeleteBuildProducts, Boolean InUpdateVersionFiles, Boolean InForceNoXGE, Boolean InUseParallelExecutor, Boolean InForceNonUnity, Boolean InForceUnity, Boolean InShowProgress, System.Collections.Generic.Dictionary`2 PlatformEnvVars) [0x00000] in <filename unknown>:0 
 MainFrameActions: Packaging (Mac):   at Project.Build (BuildCommand Command, AutomationTool.ProjectParams Params, Int32 WorkingCL) [0x00000] in <filename unknown>:0 
 MainFrameActions: Packaging (Mac):   at BuildCookRun.DoBuildCookRun (AutomationTool.ProjectParams Params) [0x00000] in <filename unknown>:0 
 MainFrameActions: Packaging (Mac):   at BuildCookRun.ExecuteBuild () [0x00000] in <filename unknown>:0 
 MainFrameActions: Packaging (Mac):   at BuildCommand.Execute () [0x00000] in <filename unknown>:0 
 MainFrameActions: Packaging (Mac): Program.Main: AutomationTool exiting with ExitCode=Error_Unknown
 MainFrameActions: Packaging (Mac): Domain_ProcessExit
 MainFrameActions: Packaging (Mac): RunUAT ERROR: AutomationTool was unable to run successfully.
 PackagingResults:Error: Error Unknown Error

Looks like a problem with the dSYM but I can see the dSYM was created and exists at that location. Why doesn't a starter project package correctly?

Product Version: UE 4.10
Tags:
more ▼

asked Mar 06 '16 at 02:26 PM in Packaging & Deployment

avatar image

shinkowski
11 2 4 4

avatar image shinkowski Mar 08 '16 at 08:18 PM

Anybody have any ideas about this?

avatar image Samantha Sutton ♦♦ STAFF Mar 09 '16 at 08:54 PM

Shinkowski,

Could you please provide me with an uploaded .txt file of your full error output logs?

Thanks!

avatar image shinkowski Mar 09 '16 at 09:04 PM

Thanks for your reply. Here's a log: package log

packagelog.txt (17.8 kB)
avatar image Samantha Sutton ♦♦ STAFF Mar 09 '16 at 09:18 PM

Hey!

  • Could you delete your Intermediate, Saved and Derived Data Cache folders found within your project folder?

  • Is this occurring with every project that you try to package?

  • Are you on UE4 from the Epic Games Launcher or did you obtain it from GitHub?

Let me know if you're still running into an error after you delete the folders. If you are, please upload those logs in case anything has changed.

Thanks!

avatar image shinkowski Mar 09 '16 at 10:08 PM

Ok I just deleted the Saved folder, Intermediate folder and Binaries folder in the project folder. There's no Derived Data Cache folder, I deleted Xcode's derived data folder. This is a C++ project and I had to run refresh Xcode project to see the schemes again in Xcode. After packaging again I got exactly the same error. I created a new C++ project and tried to package it and got the same error. I created a new BluePrint project and it packages correctly. I'm using the Epic Launcher.

avatar image Samantha Sutton ♦♦ STAFF Mar 10 '16 at 06:38 PM

Could you please try to package your project using Unreal Frontend? You can locate it within the engine by going to: Window > Project Launcher

Once you're in UFE, click on the little + button that's at the lower right side of the screen and create your own custom profile.

Another thing you can try is to open your config file at Engine/Saved/UnrealBuildTool/BuildConfiguration.xml and set bGeneratedSYMFile to false.

Let me know what happens, upload any logs obtained. Thanks!

avatar image shinkowski Mar 10 '16 at 08:20 PM

I created a brand new first person c++ project and created a new custom launch profile but get the same error. My BuildConfiguration.xml just had empty , I added bGeneratedSYMFile so now it looks like this:

 <?xml version="1.0" encoding="utf-8" ?><Configuration xmlns="https://www.unrealengine.com/BuildConfiguration">
     <BuildConfiguration>
         <bGeneratedSYMFile>false</bGeneratedSYMFile>
     </BuildConfiguration>
 </Configuration>

Here's my log when packaging from the UFE: link text Looks like the bGeneratedSYMFile isn't working. I restarted everything but it's still looking for the dSYM :(

avatar image ZeroEightSix STAFF Mar 10 '16 at 11:03 PM

What format does your Seagate_Expansion_Drive use? Is it, by any chance, case-sensitive? If so, that may be the problem.

avatar image shinkowski Mar 10 '16 at 11:16 PM

You're right. The file is called Test2.dSYM but the log says Test2.dsym. I renamed it to Test2.dsym and when I package I have Test2.dSYM and Test2.dsym. I don't get the package error anymore now.

But the problem is that the dsym could be out of date because I'm renaming it manually. Is it possible for me to change the engine code to make it look for dSYM instead of dsym or make the output file dsym instead of dSYM? I'm very new to this and have no idea where to look for that.

avatar image shinkowski Mar 11 '16 at 06:07 PM

That's great. Thank you both very much :)

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

As far as I can see, we already changed that in 4.11. It'd be trivial to do in 4.10 as well, but not in the binary version of the engine you are using. If you grab the sources from GitHub and build the editor yourself, I believe that all you need to do is modify the string returned from GetDebugFileExtentions() in Engine/Source/Programs/AutomationTool/Mac/MacPlatform.Automation.cs

more ▼

answered Mar 11 '16 at 01:42 AM

avatar image

ZeroEightSix STAFF
2.1k 18 6 36

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question