x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"permission error" when using xcode to run ue4 game on simulator

alt textWhen I try to run my ue4 game on xcode using the simulator (iPhone 6) I get the error "you don't have permission". I can package my game and run it on the actual devices with no issues. Xcode builds my game successfully and yet I can't play it on a simulator.

I have tried to get tappy chicken to run on a simulated device in xcode to see if the problem was specific to my project, but I still get the same error. For the sake of simplicity and so that the error can be reproduced by others I wiil use tappy chicken as the example for recreating the error.

I am using a MacBook pro (fully updated), OS X el capitan (new install), unreal engine 4.10.4 and xcode 7

Steps to recreate error on the mac OS X

install unreal engine 4

install tappychicken (the unreal engine 4 mobile demo project)

Set xcode and unreal projects files and folders to read and write enabled

Check user account is admin

set user account to developer mode

use disk utility to use first aid to check hard drive permissions

create certificate request using macbook pro keychain access

manually create certificate, app id and mobile provisioning profile – add to tappychicken project

in the unreal editor add code to tappy chicken project to convert it to xcode project

open tappy chicken xcode project

in build settings change product name to TappyChicken and change supported platform to ios

in general settings for tappychicken in xcode choose team, add bundle id and select developer id

choose tappychicken scheme (not UE4)

edit scheme - select development for run and set to iphone 6 simulator

delete data cache

validate settings - successful

clean - successful

build - successful

analyse – successful

When I run game for simulated device (iphone 6) I get the error "Don't have permission"

Could someone please suggest a way to fix this.

Product Version: UE 4.10
Tags:
more ▼

asked Mar 07 '16 at 07:01 PM in Packaging & Deployment

avatar image

Precision-Gaming
1 2 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi GrayWolf,

Although there is some code there, the iOS simulator is not currently supported. This feature has already been requested as [UEPLAT-182]. However, I have increased the Community Interest and added this post to the watch list so that you will be notified should this feature be added.

-Steve H.

more ▼

answered Apr 13 '16 at 05:13 PM

avatar image Precision-Gaming Apr 14 '16 at 11:03 AM

Hello Steve H,

Thank you for answering my question. It is greatly appreciated.

-GrayWolf

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question