x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Errors running dedicated server compiled from source

I have been following this guide and twice now I've started from scratch to come to the same errors.

After cooking the content and compiling the (Development) server followed by the (Development) client I launch the MultiplayerTestServer.exe -log and get this output followed by a messagebox also showing the CDO constructor errors.

Starting the client yields the same messagebox with CDO constructor errors, followed by a message with this error:

Assertion failed: GDefaultMaterials[Domain] != NULL [File:D\Projects2\Unreal Projects\EngineBuild\Engine\Source\Runtime\Engine\Private\Materials\Material.cpp] [Line: 351] Cannot load default material 'engine-ini:/Script/Engine.Engine.DefaultMaterialName'

This is the second time it's happened, am I consequently doing something wrong following the guide?

Product Version: UE 4.11 Preview
Tags:
more ▼

asked Mar 09 '16 at 10:44 PM in C++ Programming

avatar image

thejjokerr
16 6 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

For now I have fixed it by ignoring the tutorial in step 8 ("Deploy: Do not deploy") and actually choosing to deploy to my device, this set the files in the right locations.

more ▼

answered Mar 12 '16 at 11:06 AM

avatar image

thejjokerr
16 6 4 8

avatar image wbDHaderer Sep 01 '17 at 09:44 AM

I'm experiencing this issue in 4.17 where the answer above doesn't seem to apply anymore, but the problem stays the same. i've tried packaging to a .pak file aswell as to a loose content files. also tried removing the WorldGridMaterial from my game, including the editor content and rerouting the DefaultMaterial path from the BaseEngine.ini file to something that is included in the packaged content for sure. Nothing helped. I'm stuck here. Any help is appreciated.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question