x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Terrible lighting quality (4.10.4)

Heya, I'm working on a scene and I suddenly noticed that the lighting quality has dropped significantly, even when building at Production quality. I have started out from the "Lighting Quick Start" tutorial and the quality was great. Only after continuing my work, adding quite a few lights, I noticed the drop. I tried checking my Engine Scalability settings, tried removing and adding lights and checking the answerhub for similar questions (none of the answers I found helped).

If I try moving the lights, their quality gets significantly improved. But when I build the lights again, they lose quality. I've attached a couple of screenshots. The 2nd screenshot is the light I made following the tutorial (it was OK then). alt text alt text

Thanks in advance for your help!

Product Version: UE 4.10
Tags:
more ▼

asked Mar 10 '16 at 11:56 AM in Rendering

avatar image

Jono0x
21 2 3 4

avatar image Higuy8000 Mar 10 '16 at 12:24 PM

A couple things I'd look at, whats the lightmap resolution for those static meshes (like the walls next to the lights), what setting for lighting are you building with, and have you tried tweaking the lightmass settings for the level? Also, have you added a lightmass importance volume?

avatar image Jono0x Mar 10 '16 at 12:47 PM

whats the lightmap resolution for those static meshes (like the walls next to the lights)

At the time of taking the screenshots - 32. Messing around with that setting seems to help (I.E increasing it to 128 or more). The thing is, I have another, different project, where I didn't mess with this setting at all, and the lighting is fine. Is there something else at play here?

what setting for lighting are you building with

Preview, but switching to other settings including Production doesn't help much.

have you tried tweaking the lightmass settings for the level?

Doesn't seem to work.

have you added a lightmass importance volume?

Yes. When I took these screenshots it was a little out of position. I have fixed that, but I still have the same issue. Thanks!
avatar image Higuy8000 Mar 10 '16 at 12:58 PM

The last thing to look at would be the UV for the static mesh itself. If its not properly UV'd (or does not take up a decent enough texture space) you are going to continue to get lower resolution lighting. That could be why the other project looked better - the UV's were packed and done correctly.

If you are using BSP however, can you try selecting it and then in the details panel setting the lightmap resolution to something low (like 2)?

avatar image Jono0x Mar 10 '16 at 12:59 PM

I should've probably mentioned it, sorry: in both cases (this and the previous project), I'm only using the starter content included with the engine for the purpose of study. I didn't touch any of the UVs in the stater content - I had no reason to.

avatar image Higuy8000 Mar 10 '16 at 01:07 PM

Interesting - would you mind posting an image of the lightmass section from the World Settings panel? Also, are you messing with any specific settings with the lights themselves?

avatar image Jono0x Mar 10 '16 at 01:12 PM

Here you go:

alt text

I didn't mess with any light settings that I don't know of. So I only played with the settings in the basic "light" section (the ones that aren't hidden) and the "Light Profiles" section in some lights (simply using one of the engine's built in IES textures)

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

It really looks like a lightmap resolution issue - try increasing to few hundreds, definitely above 32 if it is what you have used. I believe that it is normal that you notice a better lighting when you just add a light before building your lightmaps. It seems Unreal use dynamic shadows as preview in the viewport, until you build your lightmap where they get replaced by actual baked lightmaps.

more ▼

answered Mar 11 '16 at 02:36 PM

avatar image

guillaumeb
21 4 4

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question