x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Reimport factory not called

The setup: A plugin made up of two parts, one runtime, one editor. The runtime part contains amongst other things a class inherting from USoundWave. This new asset type is imported using a custom import factory. To handle reimport we added a custom reimport factory, it's constructor is being run, but nothing else. Interestingly enough it worked earlier. Current engine version: 4.10.4. I have put breakpoints in all the functions, only the constructor is being called. The editor is getting a log message about reimporting an asset that is modified on disk. And it's showing the popup about reimporting a source asset. I can supply the code used if necessary. (Preferably non-publicly).

Thanks for any help!

Product Version: UE 4.10
Tags:
more ▼

asked Mar 10 '16 at 12:48 PM in Bug Reports

avatar image

Zicandar
31 2 5

avatar image Matthew J Mar 11 '16 at 06:36 PM

Hello Zicandar,

I can't quite tell if this is a problem in the plugin or with the engine itself but I would need to see the plugin itself to determine that. If you wish to send it privately, it would be best to send a download link to me via a private message in our forums. This is a link to my profile so that you can do so: https://forums.unrealengine.com/member.php?36033-Matthew-Clark

avatar image Zicandar Mar 16 '16 at 01:16 PM

Hello Matthew, I sent a pm with a project where I can reproduce it. Thanks for the help!

avatar image Matthew J Mar 23 '16 at 05:09 PM

I'm just leaving a comment here for tracking purposes as we are continuing to speak about this in private messages on the forums, as it involves your project's content / software.

avatar image Zicandar Mar 31 '16 at 08:18 AM

For others having this problem I have a partial update: virtual bool IsImportedAsset() const override { return true; } Is required in the AssetActions it seems. Even with this I'm only getting calls to my reimport factory IF I first reimport it via the Assets context menu.

avatar image Matthew J Apr 08 '16 at 02:56 PM

Hello Zicandar,

I'm still looking into this issue and wanted to let you know that the report hasn't been forgotten. I'll be sure to update you here if I need more information or have any more updates on the progress of this issue.

avatar image Matthew J Apr 08 '16 at 04:17 PM

You mentioned that another individual who was helping you proposed that the path data for the import was being lost and that was causing you to need to manually reimport to repopulate that. Are you or that other person aware of exactly how/when the path data is lost? It would be helpful information to know.

avatar image Zicandar Apr 11 '16 at 07:09 AM

I asked but sadly no.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Zicandar,

I apologize for the delay. While I'm still not 100% sure if this is an issue with the engine itself or with the plugin's code, I've placed a bug report in so that some people more well-versed in this subject can take a look at the problem. For reference, the bug report number is UE-29896. I'll be sure to let you know if there are any updates to the report or if we need any more information from you on the subject.

Have a nice day!

more ▼

answered Apr 25 '16 at 05:13 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question