x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Light from particle effect "Shutting off" when Walking

I am making a First Person game and I have set up some lights and particle effects. I have no triggers for turnign them on or off yet, but I am getting some strange behavior. When I walk forward everything appears fine. See Pic 1. But if I am even wit the ts is just something Unreal does that I am unfamiliar with.

alt text

alt text

Product Version: UE 4.9
Tags:
on.jpg (634.5 kB)
off.jpg (172.2 kB)
more ▼

asked Mar 11 '16 at 12:11 AM in Rendering

avatar image

BearsAirz
1 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello Bears, is the lighting coming from a particle effect or a separate light source?

more ▼

answered Mar 11 '16 at 12:25 AM

avatar image

Luos
9.2k 283 63 330

avatar image BearsAirz Mar 11 '16 at 12:28 AM

I have both currently and it goes completely dark. I think it is just culling the light source when I dont see it (as it does this in the editor as well), and I am trying to find the solution from there.

I will test if it still goes completely dark with the Particle and the Light separate.

avatar image Luos Mar 11 '16 at 12:31 AM

Thats my guess yea, once the particle isnt visible, it might shut down (especially if lods are added to the particle)

avatar image BearsAirz Mar 11 '16 at 12:34 AM

Ok, its my particle that is doing this.

avatar image Luos Mar 11 '16 at 12:53 AM

You can try to increase the bounds of the particle emitter..

(in Cascade, Click in the Black area outside of your emitter module list and then go to the details panel and Find the Fixed Bounds settings, and increase / decrease the bounds as necessary, in your case you will want to make the rooms size the fixed bounds of the system, or approximate as the center of the system is always the center of the bounds so if your fire is on a wall you may want to increase the bounds only in the direction needed to fill you room.)

or, just add a light yourself (or combine them in a blueprint), which often is more optimal anyways.

avatar image BearsAirz Mar 11 '16 at 12:58 AM

I had just solved this when I got your response xD. Thanks for the help.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Solved. I had to increase my Bounds on my particle effect.

more ▼

answered Mar 11 '16 at 12:54 AM

avatar image

BearsAirz
1 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question