x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Mouse click stutters my game

Hi,

I have a simple game based on overhead template. I have a shooting mechanism written, and I noticed that everytime I press a mouse button, left or right the game stutters a bit. Even in standalone mode. At first I thought it was about my projectile mechanism, but if I map Fire to spacebar, shooting is fast.

Clicking mouse buttons without mapping them or having blueprint events for them still makes the game stutter even if nothing is mapped to them. And I have disabled mouse actor touch, click and hover events from my Controller.

This is on OSX Maverics 10.9.2 and Unreal Engine 4.1.

Best regards, Kaali

Product Version: Not Selected
Tags:
more ▼

asked May 03 '14 at 11:35 AM in Bug Reports

avatar image

Kaali
61 5 4

avatar image Ben Halliday STAFF May 03 '14 at 06:30 PM

Hey Kaali,

I'm haven't been able to reproduce the issue you're experiencing. Does this happen in every project, or just the one? Can you tell us your system specs? Thanks!

Ben Halliday

avatar image Kaali May 03 '14 at 07:09 PM

I can repeat it by creating a top down blueprint project, get the character to move by clicking left mouse button, then click right button fast repeatedly. But I could not reproduce it with the flying template even with adding a input mapped to left mouse and adding that to a blueprint as an event.

Exact steps made for the new project: 1. Start Unreal Editor 4.1 2. Create New Project based on Top Down Blueprint 3. Disable starter content (not relevant as I have it included in another project which has the problem too) 4. Move with left mouse, quickly tap right when moving to see stutter. Or even left mouse, but right is more interesting as it is not mapped to anything.

My specs are: - MacBook Pro, Retina, 15-inch, Early 2013 - 2.8 Ghz Intel Core i7 - 16 GB 1600 Mhz DDR3 - NVidia GeForce GT 650M 1024MB

The editor is quite slow on this system, so I usually run in quick settings low mode for comfort. Editor project launcher idles at 20-40% (in Slate OnPaint and PrePass), but that is a completely unrelated issue.

avatar image ZeroEightSix STAFF May 05 '14 at 03:59 PM

Could you please be more specific on how big the performance drop is when you click? I tried the Top Down Blueprint template on a couple of Macs and while I did notice a small drop in FPS, it was only 1-2 frames per second less (when running at ~75 FPS). It may need some investigation to make sure it's justified, but I assume you're experiencing a bigger FPS drop...

What is your MacBook's display mode set to? Best for display, or maybe More space? Also, if you haven't tried this yet - could you try hiding or quitting the Unreal Engine Launcher and see if that improves things? Thanks.

avatar image Kaali May 05 '14 at 04:09 PM

I measured the numbers inside editor for this test. I get quite stable 70.9 FPS when idling. When I click right mouse button once, it quickly dips to 65ish. And when clicking in fast succession, it drops down to 54-58 FPS. The latter numbers are quite approximate as the FPS counter updates too quickly.

In a smaller window mode test I get idle FPS of 60 and it drops to 45 when clicking repeatedly.

At the moment I'm at the second to last option of more space, but I also get the dip with "best mode".

avatar image ZeroEightSix STAFF May 05 '14 at 09:06 PM

OK, many thanks for these additional details. I'll investigate this soon.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes. If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you.

more ▼

answered Oct 03 '14 at 02:05 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question