x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is my vehicle driving above the ground/collision?

I've created an vehicle. I'm able to drive, but I'm driving above the ground/collision :)

Anyone know why? I've played with wheel size etc but without any results still my car is driving above the ground and my physical asset is correct - when I simulate it it's on the ground.

alt text

Product Version: Not Selected
Tags:
bug.jpg (141.0 kB)
more ▼

asked May 03 '14 at 12:17 PM in Blueprint Scripting

avatar image

intoxicat3
677 71 92 148

avatar image DizzyWes ♦♦ STAFF May 05 '14 at 01:28 PM

Hi!

What type of Blueprint did you use for the class, Character? If so, how does the car look in the Blueprint in relation to the CapsuleComponent, could you post a screen?

-W

avatar image ngomes007 Feb 26 '17 at 07:50 PM

I'm getting the same thing, it's float alt text

screenshot_1.png (1.3 MB)
avatar image intoxicat3 May 05 '14 at 02:10 PM

I'm extending from WheeledVehicle class which doesn't have CapsuleComponent. The thing here is when I move collisions in PhysAsset down the car is in right place but I can't drive it.

Is there any console command that will show me the wheels and car components?

avatar image DizzyWes ♦♦ STAFF May 05 '14 at 02:33 PM

I'm wondering perhaps if its something with the asset, if it's working in simulation I'm not quite sure why it wouldn't be working in play. You could ShowDebug Bones to see where your wheels are when playing, but I'm assuming they'll be floating in air too.

avatar image intoxicat3 May 05 '14 at 06:54 PM

Yeah but what can be wrong? :) I can send you the assets if needed.

Showdebug Bones attached I don't know how to get informations from this debug text :(

Hope you will be able to help!alt text

showdebug_bones.jpg (127.4 kB)
avatar image DizzyWes ♦♦ STAFF May 05 '14 at 07:39 PM

If you would like to post a test asset, I can take a look.

-W

avatar image intoxicat3 May 05 '14 at 07:53 PM

Sure, there you go: https://www.dropbox.com/sh/do3y9kzkgzn0ylx/N-azYBHCvt

If you need anything else please let me know!

Hope you will find solution!

avatar image DizzyWes ♦♦ STAFF May 05 '14 at 08:11 PM

Apologies,

Would you be able to post a copy of the actual uasset files instead of the COPY files, that way I can also load up your settings too to see what's happening?

-W

avatar image intoxicat3 May 06 '14 at 06:30 AM
avatar image DizzyWes ♦♦ STAFF May 06 '14 at 04:11 PM

Still looking into what's causing this, thank you for posting the assets.

From your original post, changing the Shape Radius from 200 down to 30 for example in your Car_Wheel BP didn't have an effect correct?

-W

avatar image intoxicat3 May 06 '14 at 04:38 PM

Changing radius to 30 make the car stay on ground like in phys asset but then I can't drive - wheels are rotating but without any movement.

avatar image Arshia001 May 06 '14 at 04:40 PM

Making the wheels big enough makes the car "work" for me, but making them smaller than a certain value breaks them. It's as if the car's collision shape was bigger than it actually is.

avatar image intoxicat3 May 06 '14 at 04:56 PM

yea same here :)

avatar image Geodav May 06 '14 at 05:01 PM

just out of interest, what sort of scale are you using, eg:- compared with the UE4 character, i found when testing the vehicle code in the beta if i used the udk scorpion it didn't work but if i scaled it up by 2 (udk->UE4) then imported set it up again it worked

avatar image Arshia001 May 06 '14 at 05:20 PM

I'd jump in and try this, but the mesh I'm using was already using the 1uu->1cm scale factor (used to do that even with udk).

avatar image piinecone May 06 '14 at 07:11 PM

I feel stupid asking these questions, but just to be sure, are you using any wheel offsets? Have you tried adjusting them? Can you ascertain that your wheel radius value is appropriate for your wheels?

I can't look right now but I've been planning on digging around the wheeled vehicle instantiation code to see if I can understand how the colliders are positioned given the skeletal mesh.

avatar image intoxicat3 May 07 '14 at 07:31 PM

of course I've tried everything - when my car is near the road (when it should be) then I can't drive and it began to rotate...

avatar image intoxicat3 May 09 '14 at 07:52 PM

Wes Bunn - did you have a chance to look into the assets? Did you find anything weird?

avatar image DizzyWes ♦♦ STAFF May 09 '14 at 08:11 PM

Hello,

Apologies, but I am still looking into what's causing this as I'm not quite sure. Internally we are prepping the release of a new Vehicle Template which I've cross referenced with what you've set up and when using your settings with our vehicle model, I'm getting the same thing - so it doesn't appear to be the model itself, something with the collision settings I'm assuming.

-W

avatar image Arshia001 May 05 '14 at 02:46 PM

I'm having the same problem too...

avatar image Konkretus May 06 '14 at 09:05 PM

The only way how managed to make a car to stay on the surface was to make a physics asset a box with small height, and lifted up. This way when I set my wheels to radius as 21, my car stays perfectly on surface. If i make physics box as big as my cars body, my car floats in the air, and can be driver only with a large wheel radius.alt text

physa.jpg (284.4 kB)
avatar image Konkretus May 06 '14 at 09:06 PM

This is how it looks in gamealt text

ingame.jpg (355.7 kB)
avatar image intoxicat3 May 07 '14 at 07:27 PM

it's not working for me

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

6 answers: sort voted first

We have the same problem as Konkretus mentioned above. But the weird point is, if we set all wheels as simulated, problems'd have been solved, but as predicted, vehicle does not move in that case. If we set wheels as kinematic, wheels go under the floor, unreal detects only body collision. Any solutions?

more ▼

answered Sep 24 '14 at 05:13 PM

avatar image

burak.io
34 5 9 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Me Too. alt text

car.jpg (65.3 kB)
more ▼

answered May 06 '14 at 02:29 PM

avatar image

jinushi
1 3 5 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Try removing any wheel bodies you may have in your physics asset. The WheeledVehicleMovementComponent should create those automatically. Also, make sure your mesh's wheel radius and offset match your VehicleWheel radius and offset properties.

more ▼

answered May 07 '14 at 10:12 PM

avatar image

piinecone
537 22 32 370

avatar image intoxicat3 May 08 '14 at 10:33 AM

I've did that as well and the vehicle is on the ground but not moving. Really it can be some weird thing with mesh/code.

Iv'e tried every single option for wheels setup/phys asset/mesh skin - without result.

Will wait for Epic documentation and final vehicle implementation with this.

avatar image piinecone May 08 '14 at 02:01 PM

Can you post a screenshot of your wheel blueprint? I'm wondering if Don't Create Shape is checked or Auto Adjust Collision Size is unchecked. In any case, I think there are a lot of vehicle improvements coming in the next release so hopefully your issue will be resolved shortly.

avatar image intoxicat3 May 09 '14 at 08:00 PM
  • Don't Create Shape - on,

  • Auto Adjust Collision Size - off

When I did that: UE4 crash when pressed play.

avatar image piinecone May 09 '14 at 11:18 PM

I typically have Don't Create Shape set to False and Auto Adjust Collision Size set to True although, again, I'm not sure how relevant these settings are. It feels like there must be an errant offset in there somewhere. I'm afraid I don't know enough to be useful at this point.

avatar image jinushi May 10 '14 at 05:07 PM

Don't Create Shape On

Use Physics Asset

bad Work...

alt text

car2.jpg (71.0 kB)
avatar image jinushi May 12 '14 at 12:20 PM

Model XYZ. I now correct in this.

FBX Output...

alt text

car3.jpg (57.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

My car wheels go through the floor and I can't find a fix, I been going through this for 9 days now and I really want to punch my PC right now WHAT DO I DO

more ▼

answered Oct 19 '16 at 02:48 AM

avatar image

MA1 Productions
11 1 5

avatar image learningOver Oct 19 '16 at 03:18 AM

Old Thread!

https://answers.unrealengine.com/questions/301149/vehicle-wont-move.html

Check here I have provided a few steps to verify as the answer to his issue. You will do well to be sure your wheel configuration is correct, I list the steps in that thread how to do so.

I am fairly certain your issues is also related to your wheel configuration.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I hit this thread 10 times while trying to figure stuff out, so if you are looking like me this might help.

One of the tutorials I was looking over was probably dated and that's where my problem started.

If your custom righ is mysteriously floating but collision looks right just try and check the wheel blueprint again. The value of the wheel is Radius and not Diameter. (As it very clearly states).

The issue in depth: Unckecking the "update collision" checkbox shows the collision where you locked it via the entered values. That gives you the impression everything is correct, but the car won't touch the ground because the invisible wheel asset is 2x the size it should be if you typed in a diameter instead of a radius.

Stupidest issue to have, but it drove me up a wall for 2 days thinking the issue was the FBX... hopefully this helps someone in the same boat as me from pulling out hair :P

more ▼

answered Mar 01 '19 at 11:50 PM

avatar image

MostHost LA
16 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question