x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Line Trace Not Showing?

Good Afternoon, I am getting a little project ready for a class, however, I have run into an issue. When I was testing an inventory method, the way I had the line trace set up worked perfectly. Click the E button, the line trace would show, if it hit a specific type of actor, it would put it into the inventory. Simple enough right? Well, I put the Exact same Blueprint into the main project file that the person in charge of the level making provided me, and the line trace will no longer show up. I have tried looking through these forums, on google, youtube as well, for anything that might be able to help me, but I have been unable to figure it out. The set up is exactly the same in the other project with the same blueprint. Any help would be awesome, even ideas of what the issues could be. Thank you!alt text

Product Version: UE 4.10
Tags:
linetraceissue.jpg (730.4 kB)
more ▼

asked Mar 14 '16 at 10:09 PM in Blueprint Scripting

avatar image

UchihaKite
3 1 2 7

avatar image iKeepBelieving Mar 14 '16 at 10:43 PM

Looks pretty easy ;) Have you cheked vectors outputs?

avatar image UchihaKite Mar 14 '16 at 10:54 PM

I'm sorry >.< I am still really new to Unreal4 and Blueprints, I am not sure how to do that.

avatar image UchihaKite Mar 15 '16 at 12:58 AM

Update: I think I may have found the issue, however, how to resolve it is a mystery all in itself. I had a random thought that, hey, maybe Unreal is having a compile bug or something. So, I took out the line trace I have attached to my characters sword attack, compiled, and when I played the game and attacked with his sword, the line trace was still popping. Maybe things aren't compiling correctly?

avatar image UchihaKite Mar 14 '16 at 11:46 PM

And I have another line trace on my character for when he attacks with his sword, and that one works fine :/

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Instead of running the trace from the camera's BP component directly try using a GetPlayerCameraManager node and from that get the transform component and plug that into the GetWorldLocation and GetForwardVector nodes the line may still be tracing but might not be using the actual angled view of the camera. Also to test if it is firing in the editor during play you can pause and eject after it should have fired to see if it is indeed firing by looking for the debug line and check world location 0,0,0 when things don't know where to spawn/fire they end up there by default.

more ▼

answered Mar 15 '16 at 02:22 AM

avatar image

Black Phoenyx
4.1k 165 9 169

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question