x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Failed to load/Can't find file for asset

Hey guys, I just made an object using a master item to work with my inventory and crafting system, but a couple hours after creating it it caused these errors to pop up. I moved the Master Item file into a new folder months ago and never received an error. Is there a way to fix this without starting over? I've tried to move the file back into its original folder, but I received another error preventing me from doing so. I have since deleted the folder and am unsure what to do. I haven't messed with anything inside of the actual project file. I've only worked within the editor.

https://gyazo.com/0a3c8069c460d19d4c3478b3e6482ee9

https://gyazo.com/8697f4201d15642edbfb0f0b3869446d

Product Version: UE 4.10
Tags:
more ▼

asked Mar 15 '16 at 10:16 AM in Bug Reports

avatar image

Entropikz
113 18 21 26

avatar image Rudy Q ♦♦ STAFF Mar 15 '16 at 01:54 PM

Hello Entropikz,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved with this issue?

avatar image Entropikz Mar 15 '16 at 09:09 PM

Hey Rudy, Thank you for replying. 1. I cannot reproduce this in a clean project. I do have a backup, but its a couple of days old so I'd like to avoid using it if at all possible. 2. But to reproduce the bug all I have to do is load the editor for the broken project and these errors pop up. 3. I can provide screenshots, but the BP's are blank save a variable reference to my structure so I don't know if that will help at all.

avatar image Rudy Q ♦♦ STAFF Mar 16 '16 at 02:39 PM

Hello Entropikz,

Thank you for the additional information. Would it be possible for you to zip down the project and provide it via drop box or google drive so that I could take a closer look at it?

avatar image Entropikz Mar 17 '16 at 11:34 PM

I think I might know the problem. Are there any current errors with casting in 4.10.4? I've tried creating a new master item BP and its still causing the cast to fail. I've found that it's not a problem with the item not being found. It's a problem with the cast failing.

avatar image Rudy Q ♦♦ STAFF Mar 18 '16 at 03:32 PM

With the information I have on this issue there are no known issue that jump out at me that may be related. Could you provide screen shots of the blueprints that you are using that relate to the failed cast?

avatar image Entropikz Mar 19 '16 at 06:11 AM

These two are where the cast is failing in the add to inventory function https://gyazo.com/ba78797fa27bbb86e9e4f50f0aab3ea9 https://gyazo.com/a3d9cf87275e8586723f01865541f5eb

These two are of the trace function: https://gyazo.com/08731e8b06bfda6dce5233e30f791bae https://gyazo.com/89068bdb9d996aa952e53b5a0d20b23d

This is the logic for the functions in the first person character https://gyazo.com/0725343729932bc6c706f9f86f46bec4

This is the BP_ItemMaster blueprint https://gyazo.com/81726cbd3d2e0d5e0c7a005d2aaea5f8

avatar image Rudy Q ♦♦ STAFF Mar 21 '16 at 07:11 PM

Hello Entropikz,

After looking over the images provided. I can't really tell where Actor Traced is being set. If you are having a failed cast you will need to make sure that the references being used are valid when the cast is called. If you could provide a copy of the project I would be able to run a few tests and take a closer look to try and further narrow down what issue it is that you are seeing.

avatar image Entropikz Mar 21 '16 at 09:34 PM

The actor traced variable is set in this screenshot here. https://gyazo.com/89068bdb9d996aa952e53b5a0d20b23d

I have it set so if the line trace hits an actor and that actor has the tags associated with the structure it will destroy it and add it to the inventory.

Is there an email I can send the project in? I'm not really comfortable with sending it over this.

avatar image Rudy Q ♦♦ STAFF Mar 22 '16 at 07:28 PM

If you would like to provide your project privately, you could do so by sending me a private message on the forums.

avatar image Rudy Q ♦♦ STAFF Mar 28 '16 at 07:54 PM

Hello Entropikz,

After downloading your project and looking through it I noticed that you are using some 3rd party plugins that are not supported. Can you confirm that this issue still occurs after the removal of these plugins?

avatar image Entropikz Mar 28 '16 at 11:23 PM

Yeah it still occurs after removing the plugins. I'm assuming you mean the Rama plugins right? I have substance installed too but I don't know if that's considered a third party plugin. I removed it anyway and still had the issue occur.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hello Entropikz,

After digging through your project it appears as though you have some corrupted blueprints that are being referenced by the assets that are getting this error. For example BP_Food does not have a parent. This means that you will need to either remake this blueprint or that you will need to replace it with a back up. This appears to be the root of this issue. I hope that this information helps.

Make it a great day

more ▼

answered Apr 01 '16 at 03:29 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image Entropikz Apr 02 '16 at 02:16 AM

Thank you so much for the help. I was thinking that I would have to do that. I appreciate you taking the time to fix this for me.

avatar image Entropikz Apr 04 '16 at 12:23 AM

Hey again Rudy. I'm sorry to keep asking questions, but I tried starting over with a new blueprint for everything including the BP_ItemMaster actor. But I'm still having problems with the cast failing with everything I've tried. Would you happen to know what this problem could be caused by? It worked perfectly before all of this happened and now no matter what I do it continues to fail.

To be specific, in the function "AddToInventory" I'm casting to BP_ItemMaster and then setting the object reference to "ActorTraced". I have a debug string set to tell me if the cast fails, but it never happened before. Now every time I try and pick an item up the cast fails and I can't seem to figure out why.

avatar image Rudy Q ♦♦ STAFF Apr 07 '16 at 12:47 PM

Hello Entropikz,

Could you try placing an is valid check in front of the cast so that you can check and make sure that the ActorTraced variable is not null?

(comments are locked)
10|2000 characters needed characters left

I don't know how! but i knew it was caused by adding wrong "Parent" folder of assets. What I did was like this...

Early I added a folder called "WeaponEffectsPack" manually to MyProject->Contents:

But after getting this error I opened my folder and there was another folder called "WeaponEffects"(it was like this WeaponEffectsPack->WeaponEffects...) so I deleted added folder from UE 4.21 and re added folder "WeaponEffects" to MyProject->Content and it did the trick :)

more ▼

answered Dec 13 '18 at 12:02 PM

avatar image

Rumme
1 1 2

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question