x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Static Mesh Drops Through Floor

I just started using UE4 and was playing around with the youtube tutorial Blueprint QuickShot 4 Spawning Physics Actors, I modified the approach slightly and used the MaterialSphere from the starter content. Because the sphere was quite large after spawning I modified the blueprint slightly and re-scaled it to reduce the size. Everything worked fine until I reduced the scale below ~0.5 (for each axis), below this factor the sphere suddenly started to drop through the floor. However if I spawn multiple balls within a short period, it suddenly works again. The following Youtube video shows the problem.

Is this a bug, or do I miss something.

Regards, Tobias

alt text

Product Version: Not Selected
Tags:
blueprint.png (185.2 kB)
more ▼

asked May 07 '14 at 07:32 PM in Bug Reports

avatar image

digibert
1 1 2 2

avatar image Lovecraft_K ♦♦ STAFF May 07 '14 at 08:19 PM

Hey digibert -

I am trying to reproduce this for you, but need a little more information. Could you give me a screenshot of you BouncingBall Blueprint's component details window? Also, can you let me know if you have set up any custom gamemode or player character information. From your video it doesn't look like you have, but I don't want to assume.

Eric Ketchum

avatar image digibert May 07 '14 at 08:44 PM

Hi Eric,

as you already guessed, I didn't use any custom gamemode or player character info.

Also I attached a screenshot of the blueprint component details window: alt text

Regards, Tobias

PS. If it would be of any help, I could also try to upload the project to github or some other repository.

unbenannt.png (93.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Tobias -

I am really glad you found the Substepping and if that works for you great. You may also want to look at enabling Use CCD under Collision in the Bouncing Balls Blueprint components as that corrected the problem for me on my version of the project.

-Eric Ketchum

more ▼

answered May 12 '14 at 02:04 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 736

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Tobias -

So I might have an idea of what is causing the issue based on the screenshots you are showing me. In the components section of your bouncing ball blueprints change the scale back to 1,1,1. Since you are already setting actor scale in your blueprint, the multiple scales could be generating an issue with the physics calculations. See if that doesn't fix the issue.

Let me know if that works or if you are still having the same problem, Eric Ketchum

more ▼

answered May 08 '14 at 02:55 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 736

avatar image digibert May 08 '14 at 07:34 PM

Hi Eric,

Unfortunately this didn't fix the problem.

I created a git repository with the project, maybe this could be of any help https://bitbucket.org/digibert/unrealtestproject

Regards, Tobias

avatar image Lovecraft_K ♦♦ STAFF May 09 '14 at 01:59 PM

Hey Tobias -

I was able to successfully reproduce this issue. Thank you for your help. I am passing this along to our engineers, but I want to make sure I give them as much information as possible. On my PC, the issue starts at scaling .10,.10,.10. You had said that your issue started with a scaling of anything below .5. Can you confirm this for me and also give me your CPU specs. (Processor, Memory, Video Card and Video Memory info)?

Thanks Again Tobias -

Eric Ketchum

avatar image digibert May 09 '14 at 10:13 PM

Hi Eric,

my computer has the following specs: - 32 GByte of RAM - Intel Core i7-3840QM CPU (2.8 GHz) - NVIDIA Quadro K1000M (Feature Level 11_0), with 1926MB of dedicated video memory and 2048MB of shared system memory

Thank you for your support! Tobias

avatar image digibert May 09 '14 at 10:22 PM

Hi Eric, I checked again the scale. And everything works fine until 0.5, as soon as I change it to 0.4, the ball starts dropping through the floor.

Tobias

avatar image digibert May 11 '14 at 08:56 PM

Hi Eric, I found a solution to my problem. If I enable 'Substepping' in the Project settings (Physics->Framerate), it works correctly. I guess the problem is due to my low frame rate, which is causing problems during the physics calculation.

Regards, Tobias

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question