x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error Message: failed to load or install certificate due to an error: 'Object reference not set to an instance of an object.'

I'm having the same issue as this guy in the link below, but I entered the bundle identifier as my developer app id and the error message persists!

https://answers.unrealengine.com/questions/205070/report-an-issue-in-packaging-for-ios.html

I'm using windows 10 and created the key and CertificateSigningRequest.certSigningRequest with Open SSL Win 32. I created the certificate, apple id and provisions without any hassle. I imported the distribution provision perfectly. Now I'm trying to import the certificate and key and I get the mentioned error.

I even tried using UE4's iPhonePackager executable and I'm having the same issue.

The user rsoriano even commented on the solution where his situation seems to exactly mirror mine.

Product Version: UE 4.10
Tags:
more ▼

asked Mar 17 '16 at 12:51 AM in Packaging & Deployment

avatar image

douggames234
6 1 6 8

avatar image AndrewHurley Mar 21 '16 at 05:19 PM

Hey bodom234,

I have a few questions that you could answer to help me narrow down the cause of the issue.

  • When importing the certificate, are you trying to import a file ending with .cer or .p12?

  • Is this a source code or blueprint based project?

  • Have you attempted to open this project in Visual Studio 2015?

It seems like you have a referencing issue which could be fixed by running the 'Fix up Redirectors in Folder'

Let me know if you have further questions.

Thank you,

Andrew Hurley

avatar image douggames234 Mar 21 '16 at 06:05 PM

Thanks a lot for the reply Andrew.

  • The provision has a green checkmark next to it. alt text When I click on import certificate, I import a .cer file and then it asks "Next, please choose the key pair that you made when generating the certificate request." alt text When I select any one of those I get the error

  • This is a blueprint based project

  • I have not attempted to open the project in Visual Studio 2015

  • I tried running the "Fix up Redirectors in Folder" in the editor and nothing seems to have changed.

I opened the certificate file just now and it seems the error could be caused be the certificate and not the key?

This might mean that I have to use a Mac computer?

alt text

ue4errorpic1.png (10.3 kB)
ue4errorpic3.png (4.8 kB)
ue4errorpic2.png (21.3 kB)
avatar image AndrewHurley Mar 21 '16 at 08:49 PM

Take a look at the our Advanced iOS PC/Mac Workflow and review your workflow to make sure you have follow all the correct steps in the correct order.

Let me know if you have further questions.

Cheers,

Andrew Hurley

avatar image RoadStar Jun 14 '18 at 10:35 AM

Hi, Andrew! Sorry for writing in quite old conversation. I just would say what if you have Certificate created on Mac, then you'll have a problem to make a build on PC. The problem is: you can get this error when importing your certificate, even if you have .p12 exported from keychain on Mac: alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Apparently I needed to use just the .p12 file when importing the certificate. My issue was renaming the .key file to .p12 instead of actually generating the .p12 with openSSL!

This entire process can be done with Windows 10 and I installed my game on my iPhone.

I used this website for the conversion (steps 1 and 3):

Adobe openSSL Link

OpenSSL is usually located in: C:\Program Files\Epic Games\4.10\Engine\Binaries\DotNET\IOS or wherever your iPhonePackager.exe file is located

more ▼

answered Mar 23 '16 at 02:33 AM

avatar image

douggames234
6 1 6 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question