x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

An Unreal process has crashed

Hello! Since about a year me and my friend are developing a game. Normally, i was developing only huds, textures, animations, 3D projects and so on with various software, but I've never really worked on the project in UE4. So when my friend went on a vacation, he left me in his office (a.k.a garage, lol) to continue work on the project alone. He had everything installed like UE4, etc, so all i had to do it just click Launch Unreal Engine and start working. Everything was going perfectly until i get that BSOD (Blue Screen of Death) and the computer just didn't wanted to start again. Next day i went to a computer service and explained the problem. They looked at the computer and said that they can save my desired information, but a windows reinstall will be required in order to make the computer work again. So they reinstalled the OS, the computer was working again and the project has been saved. Now i had to download UE4 again, so i registered my own account, downloaded the launcher then downloaded and installed UE4.10.4 (the previous installation was 4.10.3, but i cant find it in the older releases), so i guess it's just the same with some minor update or something, but anyway... I installed UE4 and attempted to open the project. Unfortunately, UE4 crashed at 93% with error: An Unreal process has crashed.

Here is the error log i get when UE4 crashes: http://pastebin.com/HMNdWVQZ

I am so sad, i don't know what happened, what i did ? We worked so hard on that project, what should i say to him when he get back, omg ... I don't know what to do, please help me ANYONE ...

Product Version: UE 4.10
Tags:
more ▼

asked Mar 18 '16 at 06:40 AM in Bug Reports

avatar image

StewenJJ
1 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Based on your error messages you might try the information from this post https://answers.unrealengine.com/questions/147813/how-do-i-get-rid-of-incompatible-version-warning.html https://answers.unrealengine.com/questions/146904/casting-blueprint-getting-nullptr.html

you also might try this. because you're getting a nullptr issue.

more ▼

answered Mar 18 '16 at 02:54 PM

avatar image

bombmask
21 3 2 5

avatar image StewenJJ Mar 18 '16 at 04:16 PM

I get rid of the warning, but the project still crashes at 93% with the nullptr error:

[2016.03.18-16.08.35:445][ 0]LogWindows:Error: Windows GetLastError: The operation completed successfully. (0) [2016.03.18-16.08.35:754][ 0]LogWindows:Error: === Critical error: === Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\CoreUObject\Private\Templates\Casts.cpp] [Line: 11] Cast of nullptr to UserDefinedStructEditorData failed

avatar image bombmask Mar 18 '16 at 05:07 PM

well 93% is usually where they start doing shader compilation. And possibly blueprint compilation. Maybe see if you can backdate your project to 4.9 (make a backup of your working copy) and see if it works there and try and debug that. Do you have any C++ code in your project? or a plugin?

avatar image StewenJJ Mar 18 '16 at 05:15 PM

Honestly, i don't really know where exactly is the C++ code in the project, but i assume there is since it is a C++ based project. I think some of the blueprints are C coded don't know about other things. As i said above, i haven't really worked on the project in UE4. Now i am installing 4.9 and will post the results later. Thank you.

avatar image StewenJJ Mar 18 '16 at 07:43 PM

Okay downloaded 4.9.2 and when I clicked "Switch Unreal Version" and picked 4.9.2 it generated the source files again. When the source code generation complete, i tried to open the project. A window pops up saying i have to rebuild some files, so i clicked ok and it started building. When it was finished, it attempted to open the project, but this time it crashes at 95% saying:

Failed to open map file. This is most likely because the map was saved with a newer version. When click ok, crash reporter starts saying:

An unreal process has crashed. No minidump found for this crash.

In the error log it was saying that there's some broken files, which i removed from the project.

Successfully opened the project in UE4.9.2, but there is nothing inside! All the .uasset files are there, i can see them in the windows explorer, but they are not loaded in the project.

avatar image bombmask Mar 19 '16 at 05:25 PM

Hmmm that's really strange. Well the C++ is in the folder called "Source" and then in there there should be a few folders for C++. Maybe look in there to see if any of those files are causing issues, specifically casting one object to another before checking if the object is valid.

I'd take a look at the source if you wanted to send it to me.

avatar image Doug E ♦♦ STAFF Mar 21 '16 at 08:15 PM

Hey StewenJJ-

It is likely that a class or blueprint where a cast was being made isn't being read properly. The first thing to test is to remove the Content folder from project directory (save a copy to the desktop or elsewhere to replace later) and try to open the project. If the project opens after removing the Content folder then it is likely a blueprint that is causing the problem and you can replace the Content folder and remove subfolders/specific bluerpints to find the one causing the problem.

If you are unable to open the project after removing the Content folder, then the issue likely lies in the source code for the project, if you could zip the Source folder and post it I can look over the files for any likely errors. If privacy is a concern you can instead upload the zip file to google drive or dropbox and send me a PM on the forums with a download link.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question