x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

why won't timeline change light & fog colors?

I am trying to change the fog inscattering color and the color of a dynamic directional light using a timeline. the timeline is also changing a parameter value. the parameter changes just fine, but nothing happens to the fog or light color. i can make these changes manually in the editor and see the difference, but the timeline doesn't appear to be making the same changes. Here is my blueprint : alt text

Product Version: UE 4.10
Tags:
more ▼

asked Mar 18 '16 at 02:51 PM in Blueprint Scripting

avatar image

swampmonster
3 3 3

avatar image Black Phoenyx Mar 18 '16 at 05:07 PM

Try disconnection the Glow variable from the New Time pin and set it back to 0...then test it again

avatar image swampmonster Mar 18 '16 at 05:55 PM

thanks for the reply. i disconnected the glow variable, compiled and ran with no change. the glow parameter changes like it should, which makes me think the problem is after the timeline, not before. i dragged the fog and light actors to the blueprint, so the references should be right.

avatar image Black Phoenyx Mar 18 '16 at 06:37 PM

This is in the level blueprint correct?

avatar image swampmonster Mar 18 '16 at 06:43 PM

yes , level bp with a tick event.

avatar image swampmonster Mar 18 '16 at 06:20 PM

i checked the color values coming out of the timeline and they are changing. for some reason, the fog and the light are not getting or displaying the changes.

avatar image Black Phoenyx Mar 18 '16 at 06:32 PM

Can you post a screen shot of the timeline?

avatar image swampmonster Mar 18 '16 at 06:45 PM

alt text

glowtimeline.png (30.2 kB)
colortimeline.png (35.5 kB)
avatar image swampmonster Mar 18 '16 at 06:33 PM

for fun, i created a vector with 2 sets of keyframes for xyz values ranging from 0 - 1, and plugged that into the fog color with no change.

avatar image Black Phoenyx Mar 18 '16 at 06:39 PM

Try something like this to see if it sets a color for the light: alt text

...it should I think it might be the timeline that is causing this

setlightcolor.png (64.3 kB)
avatar image swampmonster Mar 18 '16 at 06:50 PM

that works. so can you not use timelines to control the color of light and fog actors, or do i have to convert the color output somehow? i think i tried breaking the color output and plugging it into a make linear color before...

avatar image Black Phoenyx Mar 18 '16 at 06:57 PM

You can but I think because of the length of the timeline you aren't seeing the changes maybe?...shorten it and test it with a shorter time span to see if it updates at all

avatar image Black Phoenyx Mar 18 '16 at 06:58 PM

I am trying to duplicate your setup to see if I can get it to work

avatar image Black Phoenyx Mar 18 '16 at 07:09 PM

I'm able to use a timeline to update the light color no problem I ran the timeline off begin play on loop:

alt text alt text alt text

What condition are you checking at the branch to run the reverse maybe it is firing play and reverse right away?

avatar image swampmonster Mar 19 '16 at 01:27 AM

i'm checking the rotation of a directional light with a <=0. again the confusing thing is that my glow parameter works fine, and when i print from the color output on the timeline, it changes like it should. alt text

pretimeline.png (149.3 kB)
avatar image swampmonster Mar 19 '16 at 01:35 AM

i made a new timeline and ran it on loop off of begin play and it worked with no problem.

avatar image Black Phoenyx Mar 19 '16 at 01:51 AM

Then there is something setup wrong in the original time...take a look at its settings

avatar image swampmonster Mar 19 '16 at 03:38 AM

i changed the transition of the timeline to 5 seconds and now it works, 10 was still too long. it is interesting that the parameter could have a timeline of 40 secs but the color change was limited to ~5. thanks for your help.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Do you have the length set at the top of the timeline to reflect the full length?...the default length is always set to 5...but you can adjust that at the top.

more ▼

answered Mar 19 '16 at 04:09 AM

avatar image

Black Phoenyx
4.1k 165 9 170

avatar image swampmonster Mar 19 '16 at 08:05 PM

wow, i didn't even know about the length and it was staring me in the face the whole time. i changed the length and checked the last keyframe next to it and that fixed all my problems. thanks so much black phoenyx, i don't know how long it would have taken me to figure out this simple bit without your help.

avatar image Black Phoenyx Mar 20 '16 at 01:29 AM

No problem, glad you got it working. Don't forget to mark this as resolved.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question