x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Custom HUD stops Particles rendering in fullscreen (F11)

I created a new HUD blueprint, inside it is this code: alt text

The Widget it is trying to create is here: alt text

I've set some of those bars to hidden and have the widget play an animation on BeginPlay (With a 1 sec delay) this is so the NEW EVENT slides in smoothly.

The adverse affects it has on particles are strange, It causes particles to not render correctly in F11/Fullscreen mode with the HUD enabled and active.

Below is an image of my character respawning with one of the UE4 default particle emitters: alt text

However in fullscreen this happens: alt text

It was hard to capture the shot so ignore the fact my character is missing, because that's part of the code.

Here is a shot of the particle too: alt text

This only happens when the Event Begin Play exec is connected to the AddWidget/SpawnWidget, otherwise it runs fine.

What is causing this?

Product Version: UE 4.10
Tags:
hud.jpg (208.7 kB)
hudwidget.jpg (237.0 kB)
respawnsmall.jpg (43.7 kB)
respawnf11.jpg (63.6 kB)
particle.jpg (226.0 kB)
more ▼

asked Mar 21 '16 at 03:00 PM in Rendering

avatar image

Nemecys
90 11 18 219

avatar image Nemecys Apr 22 '16 at 12:46 AM

Hi,

Can I get some feedback regarding this issue, as what i have also noticed is that the side of the screen creates a blur/smudging/light bleed issue just like this Top Down game, mentioned here: https://answers.unrealengine.com/questions/177571/47-f11-fullscreen-editor-border-black-1.html

This happens on the top while mine is on the Left, so I assume this is an issue persisting in the engine that is also related to the fact my particles don't show.

This issue dissipated for a short while but has returned and brought the particle problem along with it.

avatar image arsenicblithely Apr 26 '16 at 02:58 AM

I'm having a similar issue. My particles work perfectly in a window, but as soon as I go fullscreen, they break. Like, if I go fullscreen with particles active, they'll suddenly freeze. While fullscreen, particles will either not spawn, or spawn way out of place. Going back to the default HUD solves the problem completely.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question