x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do I stop light from effecting a single asset??

It should be a pretty regular problem but there are no tutorials on how to do this.

A common problem would be a lamp shade. How do you simulate light coming through the lamp shade without having it cast the shadow of sed Lamp shade. alt text An example is of this is my hanging lamp. I have a point light inside to simulate the bulb light, allowing a concentration of light to hit the floor and sealing. But the light being partially transparent it should allow light to travel though. I then create a secondary light also inside the lamp. But the only way to allow light to travel though the lamp is to un-tick 'cast shadows'. This also resulting in no shadows to to cast from the ceiling beams.

In short, to resolve this I would only need to stop the lamp being effected by the secondary light. But how can I do this????

Thanks.

Product Version: UE 4.7
Tags:
1.jpg (256.2 kB)
more ▼

asked Mar 22 '16 at 06:10 PM in Using UE4

avatar image

Gilbert159
23 1 6 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Gilbert, in 4.11 you will be able to include/exclude objects to certain lights. https://forums.unrealengine.com/showthread.php?94321-Unreal-Engine-4-11-Preview&p=460725&viewfull=1#post460725

That said, there might be other ways, but its beyond my expertise.

more ▼

answered Mar 23 '16 at 01:20 AM

avatar image

Luos
9.3k 286 64 330

avatar image Gilbert159 Mar 23 '16 at 01:28 PM

Ahhhh ok thanks. Looks like ill have to wait haha. Any suggestions how i could get around this problem?

avatar image Jacky Mar 24 '16 at 06:49 PM

A workaround is to set the part of the lamp you dont want casting shadows as a separate material ID in your modeling program. Then in the editor > static mesh editor you can disable shadows for that material ID.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question