x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Servertravel crashes editor

MachineId:70DF8DDD46A53AE7EF7A70A41E579D07 Crashing when I try to exequte console command servertravel in blueprint. Everything worked fine but today I had some experiments with my project. Didn't make test play for a while and can't say when it started to happen. Please help.

Product Version: UE 4.10
Tags:
more ▼

asked Mar 22 '16 at 11:13 PM in Bug Reports

avatar image

Ffdspline
1 1 3

avatar image Sean L ♦♦ STAFF Mar 23 '16 at 01:08 PM

Hello,

Are you using 4.10.4? If not, go ahead and update your engine version and give it another shot. This seems related to UE-27124, which is a crash related to switching levels, and was reported as fixed in 4.10.4.

avatar image Ffdspline Mar 23 '16 at 01:13 PM

This entire project was made in 4.10.4 version. I had some troubles with updating project to 4.10 and decided to recreate it in new version.

avatar image Sean L ♦♦ STAFF Mar 23 '16 at 01:17 PM
  • Have you been able to narrow down steps to reproduce this issue in a clean project?

  • Have you attempted to do the same thing in the 4.11 preview to see if it crashes there as well?

  • Could you provide the logs from your project's Saved->Logs folder after the crash occurs?

avatar image Ffdspline Mar 23 '16 at 01:59 PM
  • Yeah, first of all I downgraded my project to it working state. It doesn't help :( But I am not sure about 1 thing. One of last things I created was a new game state and had some experiments with timers. When I got this troubles I tried to remove this game state and got some weird "cast failed" errors on compiling widget blueprint that displays timer to player. I dont know why, cause I removed everything connected to game state bp. Reloaded my project and this problem disappeared. Well now I don't understand what is going on at all.

  • No I have no 4.11. My internet connection sucks and currently I am stuck with 4.10

  • Yes but later a bit. Rightnow I have no access to my home pc.

avatar image Sean L ♦♦ STAFF Mar 23 '16 at 02:31 PM

Please let me know when you get the logs uploaded.

I'd like you to attempt a test when you have a minute.

  • Create a new, blank project.

  • Create 2 maps (Map 1 and Map 2).

  • Open Map 1.

  • PIE

  • Open the console using the ~ key.

  • Type Open Map2 and press enter

  • After the transition completes, open the console again and type Open Map1

Let me know if this causes the project to crash for you.

avatar image Ffdspline Mar 23 '16 at 06:24 PM

Just made an expected crash and this log generated. link text

Made a test with 2 maps. Everything works fine.

gamelog.log (54.9 kB)
avatar image Ffdspline Mar 23 '16 at 06:38 PM

Btw, in the previous project servertravel works fine. Just checked out.

avatar image Sean L ♦♦ STAFF Mar 23 '16 at 07:14 PM

If the server travel seems to be working, what changes did you make to the project before it began crashing? We'll need to attempt to identify what steps are causing the crash.

avatar image Ffdspline Mar 23 '16 at 07:18 PM

Well, at this point I have no idea. Rightnow I am trying to recreate whole project by simple copypasting blueprint contents.

avatar image Sean L ♦♦ STAFF Mar 23 '16 at 07:25 PM

Okay, with this method, the best thing to do would be to compile and play after you add each blueprint back into the new project. That way you can tell exactly which blueprint is causing the project to crash. If you discover this, please let me know which blueprint is causing the issue, and provide a screenshot of that blueprint.

avatar image Ffdspline Mar 25 '16 at 09:39 AM

Ok. I recreated my project and everything works fine. It is literally clone of my bugged project. I have no idea what gone wrong. Well, I can archive unpacked project and upload it somwhere if you want to find out what is going on.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello,

It's possible that some of the assets became corrupted, and recreating them solved your issue. If this issue comes back at any point, please feel free to reopen this thread. For now, I will be marking this topic as resolved, as recreating your project seems to have fixed your crash.

Have a great day

more ▼

answered Mar 28 '16 at 03:15 PM

avatar image

Sean L ♦♦ STAFF
44k 485 149 438

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question